python-packaging: Update to 23.2
authorJeffery To <jeffery.to@gmail.com>
Tue, 3 Oct 2023 14:59:58 +0000 (22:59 +0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 3 Oct 2023 23:55:10 +0000 (16:55 -0700)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-packaging/Makefile
lang/python/python-packaging/test.sh [new file with mode: 0644]

index cb4e0d039b5efa5e73b96222c059d87003b3d96a..1bec008bea4dcbcfc9e31542c0cc202ceb3268f1 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-packaging
-PKG_VERSION:=23.1
+PKG_VERSION:=23.2
 PKG_RELEASE:=1
 
 PYPI_NAME:=packaging
-PKG_HASH:=a392980d2b6cffa644431898be54b0045151319d1e7ec34f0cfed48767dd334f
+PKG_HASH:=048fb0e9405036518eaaf48a55953c750c11e1a1b68e0dd1a9d62ed0c092cfc5
 
 PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>, Jeffery To <jeffery.to@gmail.com>
 PKG_LICENSE:=Apache-2.0 BSD-2-Clause
@@ -32,7 +32,7 @@ define Package/python3-packaging
   SUBMENU:=Python
   TITLE:=Core utilities for Python packages
   URL:=https://github.com/pypa/packaging
-  DEPENDS:=+python3-light +python3-logging +python3-urllib
+  DEPENDS:=+python3-light +python3-email +python3-logging +python3-urllib
 endef
 
 define Package/python3-packaging/description
diff --git a/lang/python/python-packaging/test.sh b/lang/python/python-packaging/test.sh
new file mode 100644 (file)
index 0000000..4fc13ba
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+[ "$1" = python3-packaging ] || exit 0
+
+python3 - << EOF
+import sys
+from packaging.version import Version, parse
+v1 = parse("1.0a5")
+v2 = Version("1.0")
+sys.exit(0 if v1 < v2 else 1)
+EOF