package/busybox: add upstream udhcp hostname truncation fix, bump release number
authorNicolas Thill <nico@openwrt.org>
Wed, 19 May 2010 21:39:10 +0000 (21:39 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 19 May 2010 21:39:10 +0000 (21:39 +0000)
SVN-Revision: 21510

package/busybox/Makefile
package/busybox/patches/000-upstream-dhcpd.patch [new file with mode: 0644]

index 3b93a0575d4063cec3b5a08663e82224c618149e..60daf8d7d4aa69893a39423db19f80446f41a913 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.16.1
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.busybox.net/downloads \
diff --git a/package/busybox/patches/000-upstream-dhcpd.patch b/package/busybox/patches/000-upstream-dhcpd.patch
new file mode 100644 (file)
index 0000000..eef33f8
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/networking/udhcp/leases.c
++++ b/networking/udhcp/leases.c
+@@ -64,6 +64,8 @@ struct dyn_lease* FAST_FUNC add_lease(
+               oldest->hostname[0] = '\0';
+               if (hostname) {
+                       char *p;
++
++                      hostname_len++; /* include NUL */
+                       if (hostname_len > sizeof(oldest->hostname))
+                               hostname_len = sizeof(oldest->hostname);
+                       p = safe_strncpy(oldest->hostname, hostname, hostname_len);