pciutils: remove eudev dependency 2549/head
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 24 Mar 2016 06:42:20 +0000 (07:42 +0100)
committerStijn Tintel <stijn@linux-ipv6.be>
Sun, 27 Mar 2016 02:34:49 +0000 (04:34 +0200)
Disable udev hwdb support instead of depending on eudev. This restores
the old behavior of pciutils. It never depended on udev.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
utils/pciutils/Makefile

index 28c47668ea4763ea88cd3553858e03985df03bcf..209a3ed09b157b422476c4da1217147053628308 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
 PKG_VERSION:=3.4.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -29,7 +29,7 @@ define Package/pciutils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
   URL:=http://mj.ucw.cz/pciutils.shtml
-  DEPENDS:=+eudev +libkmod +zlib
+  DEPENDS:=+libkmod +zlib
 endef
 
 define Package/pciutils/description
@@ -48,6 +48,7 @@ MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include" \
        PREFIX="/usr" \
        HOST="$(GNU_TARGET_NAME)" \
+       HWDB="no" \
        ZLIB="yes"
 
 ifneq ($(CONFIG_USE_GLIBC),)