etherwake: Remove obsolete uClibc patch
authorRosen Penev <rosenp@gmail.com>
Sun, 14 Jul 2019 23:57:12 +0000 (16:57 -0700)
committertripolar <tripolar@users.noreply.github.com>
Sun, 21 Jul 2019 10:30:52 +0000 (12:30 +0200)
No such issue with uClibc-ng.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/etherwake/Makefile
net/etherwake/patches/100-no_ether_hostton.patch [deleted file]

index 9a0b9ba80459caa7468ebcf647725ed53684465e..98063c036e2739907cc92e4cb2de0241f06a9bd1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=etherwake
 PKG_VERSION:=1.09
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
 PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/e/etherwake
diff --git a/net/etherwake/patches/100-no_ether_hostton.patch b/net/etherwake/patches/100-no_ether_hostton.patch
deleted file mode 100644 (file)
index e33c06b..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
---- etherwake-1.09.orig/ether-wake.c   2005-07-10 20:44:25.000000000 +0200
-+++ etherwake-1.09.orig.no_ether_hostton/ether-wake.c  2007-04-29 19:03:41.000000000 +0200
-@@ -15,7 +15,11 @@
- "     an optional password appended.\n"
- "\n"
- "     The single required parameter is the Ethernet MAC (station) address\n"
-+#if !defined(__UCLIBC__)
- "     of the machine to wake or a host ID with known NSS 'ethers' entry.\n"
-+#else
-+"     of the machine to wake.\n"
-+#endif
- "     The MAC address may be found with the 'arp' program while the target\n"
- "     machine is awake.\n"
- "\n"
-@@ -289,16 +293,22 @@
-               if (debug)
-                       fprintf(stderr, "The target station address is %s.\n",
-                                       ether_ntoa(eaddr));
-+#if !defined(__UCLIBC__)
-       } else if (ether_hostton(hostid, eaddr) == 0) {
-               if (debug)
-                       fprintf(stderr, "Station address for hostname %s is %s.\n",
-                                       hostid, ether_ntoa(eaddr));
-+#endif
-       } else {
-               (void)fprintf(stderr,
-                                         "ether-wake: The Magic Packet host address must be "
-                                         "specified as\n"
-+#if !defined(__UCLIBC__)
-                                         "  - a station address, 00:11:22:33:44:55, or\n"
-                                         "  - a hostname with a known 'ethers' entry.\n");
-+#else
-+                                        "  - a station address, 00:11:22:33:44:55\n");
-+#endif
-               return -1;
-       }
-       return 0;