Fix pmacct and snort dependencies
authorNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 10:41:22 +0000 (10:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 18 May 2005 10:41:22 +0000 (10:41 +0000)
SVN-Revision: 923

openwrt/package/Makefile

index 9b54af292c2b78817f4084eec96a04771e662104..b5573a14e3418f0e1bbb0581edb37ee7fe663449 100644 (file)
@@ -144,9 +144,16 @@ siproxd-compile: libosip2-compile
 sipsak-compile: openssl-compile
 lighttpd-compile: openssl-compile pcre-compile
 osiris-compile: openssl-compile
-pmacct-compile: libpcap-compile
 freeradius-compile: libtool-compile mysql-compile openldap-compile openssl-compile postgresql-compile
 
+pmacct-compile: libpcap-compile
+ifneq ($(BR2_PACKAGE_PMACCT_MYSQL),)
+pmacct-compile: mysql-compile
+endif
+ifneq ($(BR2_PACKAGE_PMACCT_PGSQL),)
+pmacct-compile: postgresql-compile
+endif
+
 snort-compile: libnet-compile libpcap-compile pcre-compile
 ifeq ($(BR2_PACKAGE_SNORT_MYSQL),y)
 snort-compile: mysql-compile
@@ -154,6 +161,9 @@ endif
 ifeq ($(BR2_PACKAGE_SNORT_PGSQL),y)
 snort-compile: postgresql-compile
 endif
+ifeq ($(BR2_PACKAGE_SNORT_ENABLE_INLINE),y)
+snort-compile: iptables-compile
+endif
 
 sdk-compile: $(DEV_LIBS_COMPILE) $(SDK_DEFAULT_COMPILE) openwrt-install
 $(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install