node: bump to v16.17.0
authorHirokazu MORIKAWA <morikw2@gmail.com>
Tue, 23 Aug 2022 02:44:16 +0000 (11:44 +0900)
committerNick Hainke <vincent@systemli.org>
Tue, 23 Aug 2022 06:24:51 +0000 (08:24 +0200)
Notable Changes:
Experimental command-line argument parser API
Experimental ESM Loader Hooks API
Experimental test runner
Improved interoperability of the Web Crypto API

Dependency updates:
Updated Corepack to 0.12.1
Updated ICU to 71.1
Updated npm to 8.15.0
Updated Undici to 5.8.0

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node/Makefile
lang/node/patches/003-path.patch
lang/node/patches/007-fix_host_build_on_macos.patch
lang/node/patches/010-execvp-arg-list-too-long.patch
lang/node/patches/999-cast_for_mips32.patch
lang/node/patches/999-delete_unnecessary_libraries_for_host_execute.patch
lang/node/patches/999-localhost-no-addrconfig.patch
lang/node/patches/999-v8_zlib_support.patch

index 811e07269aa14ddd3d1844f5c24e0c336ddd8a03..9a6c694be7b75aeb85a4d65dfc1a1c7dc142ab70 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=node
-PKG_VERSION:=v16.16.0
+PKG_VERSION:=v16.17.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=145151eff3b2aa5ebe73384009c52271a83740ae687a93c98c628cd7d52736eb
+PKG_HASH:=1d28c285685e446985921bc963565ca9c0c5f4fda9755e489c06808ea9795645
 
 PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
 PKG_LICENSE:=MIT
index d18af1d73e4aa93e02d217aab6309393f97e80b1..9599cbfeccd11de2710cce74680efa7ee07a83b1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/internal/modules/cjs/loader.js
 +++ b/lib/internal/modules/cjs/loader.js
-@@ -1240,7 +1240,8 @@ Module._initPaths = function() {
+@@ -1261,7 +1261,8 @@ Module._initPaths = function() {
      path.resolve(process.execPath, '..') :
      path.resolve(process.execPath, '..', '..');
  
index a228c9bda2aa726c3d14880e82c5c11ffc14b6ca..5def2bd4310168e68e25b9dedf3fabbeae01b6bc 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tools/gyp/pylib/gyp/generator/make.py
 +++ b/tools/gyp/pylib/gyp/generator/make.py
-@@ -179,7 +179,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
+@@ -181,7 +181,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
  
  LINK_COMMANDS_MAC = """\
  quiet_cmd_alink = LIBTOOL-STATIC $@
index 821c5816b744f173a61620b79a1301adfc0458e0..8074ba149c21fed3531eb94592cb045b366746be 100644 (file)
                  "%s: LD_INPUTS := %s"
 --- a/tools/gyp/pylib/gyp/generator/make.py
 +++ b/tools/gyp/pylib/gyp/generator/make.py
-@@ -154,6 +154,32 @@ cmd_alink_thin = rm -f $@ && $(AR.$(TOOL
+@@ -156,6 +156,32 @@ cmd_alink_thin = rm -f $@ && $(AR.$(TOOL
  quiet_cmd_link = LINK($(TOOLSET)) $@
  cmd_link = $(LINK.$(TOOLSET)) -o $@ $(GYP_LDFLAGS) $(LDFLAGS.$(TOOLSET)) -Wl,--start-group $(LD_INPUTS) $(LIBS) -Wl,--end-group
  
  # We support two kinds of shared objects (.so):
  # 1) shared_library, which is just bundling together many dependent libraries
  # into a link line.
-@@ -198,6 +224,32 @@ cmd_alink = rm -f $@ && $(AR.$(TOOLSET))
+@@ -200,6 +226,32 @@ cmd_alink = rm -f $@ && $(AR.$(TOOLSET))
  quiet_cmd_alink_thin = AR($(TOOLSET)) $@
  cmd_alink_thin = rm -f $@ && $(AR.$(TOOLSET)) crsT $@ $(filter %.o,$^)
  
  # Due to circular dependencies between libraries :(, we wrap the
  # special "figure out circular dependencies" flags around the entire
  # input list during linking.
-@@ -1768,21 +1820,35 @@ $(obj).$(TOOLSET)/$(TARGET)/%%.o: $(obj)
+@@ -1809,21 +1861,35 @@ $(obj).$(TOOLSET)/$(TARGET)/%%.o: $(obj)
                  self.flavor not in ("mac", "openbsd", "netbsd", "win")
                  and not self.is_standalone_static_library
              ):
index 73493306fb0d753cb620c740a3b0bc1c471e248e..a83157b80232036aa59e64328b802ccc5d0192fe 100644 (file)
@@ -1,6 +1,6 @@
 --- a/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
 +++ b/deps/v8/src/compiler/backend/mips/code-generator-mips.cc
-@@ -4230,7 +4230,7 @@ void CodeGenerator::AssembleReturn(Instr
+@@ -4103,7 +4103,7 @@ void CodeGenerator::AssembleReturn(Instr
      } else if (FLAG_debug_code) {
        __ Assert(eq, AbortReason::kUnexpectedAdditionalPopValue,
                  g.ToRegister(additional_pop_count),
index 7a01196c8f527841fda51b44f857634e5fb1778c..7648b59ffd893c5ce9c40bbf618a6d925d0a4e61 100644 (file)
@@ -34,7 +34,7 @@
          '<@(icu_src_genccode)',
 --- a/tools/v8_gypfiles/v8.gyp
 +++ b/tools/v8_gypfiles/v8.gyp
-@@ -1363,6 +1363,7 @@
+@@ -1365,6 +1365,7 @@
      {
        'target_name': 'bytecode_builtins_list_generator',
        'type': 'executable',
@@ -42,7 +42,7 @@
        'conditions': [
          ['want_separate_host_toolset', {
            'toolsets': ['host'],
-@@ -1387,6 +1388,8 @@
+@@ -1389,6 +1390,8 @@
      {
        'target_name': 'mksnapshot',
        'type': 'executable',
@@ -51,7 +51,7 @@
        'dependencies': [
          'v8_base_without_compiler',
          'v8_compiler_for_mksnapshot',
-@@ -1408,6 +1411,7 @@
+@@ -1410,6 +1413,7 @@
      {
        'target_name': 'torque',
        'type': 'executable',
@@ -59,7 +59,7 @@
        'dependencies': [
          'torque_base',
          # "build/win:default_exe_manifest",
-@@ -1446,6 +1450,7 @@
+@@ -1448,6 +1452,7 @@
      {
        'target_name': 'torque-language-server',
        'type': 'executable',
@@ -67,7 +67,7 @@
        'conditions': [
          ['want_separate_host_toolset', {
            'toolsets': ['host'],
-@@ -1473,6 +1478,8 @@
+@@ -1475,6 +1480,8 @@
      {
        'target_name': 'gen-regexp-special-case',
        'type': 'executable',
index 84a906faf076772f7c6ef659896ca93493c25939..b81c59eef2675899800424387e516673618eaf51 100644 (file)
@@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
  //
  // Permission is hereby granted, free of charge, to any person obtaining a
  // copy of this software and associated documentation files (the
-@@ -1059,13 +1060,6 @@ function lookupAndConnect(self, options)
+@@ -1118,13 +1119,6 @@ function lookupAndConnect(self, options)
      hints: options.hints || 0
    };
  
index 08e4312c931576766ec4501c2bacd7da37268ff8..efb2c99ee4ac82d70268d6be1e0b46e8254c9ce0 100644 (file)
@@ -59,7 +59,7 @@
          'include_dirs': [
            '<(generate_bytecode_output_root)',
            '<(SHARED_INTERMEDIATE_DIR)',
-@@ -1343,6 +1349,7 @@
+@@ -1345,6 +1351,7 @@
          }],
        ],
        'direct_dependent_settings': {
@@ -67,7 +67,7 @@
          'include_dirs': [
            '<(V8_ROOT)/include',
          ],
-@@ -1691,6 +1698,7 @@
+@@ -1693,6 +1700,7 @@
           }],
        ],
        'direct_dependent_settings': {
@@ -75,7 +75,7 @@
          'include_dirs': [
            '<(V8_ROOT)/include',
          ],
-@@ -1871,15 +1879,19 @@
+@@ -1873,15 +1881,19 @@
          }],
        ],
        'direct_dependent_settings': {