batman-adv: Load module with AutoProbe
authorSven Eckelmann <sven@narfation.org>
Tue, 5 Jun 2018 12:28:39 +0000 (14:28 +0200)
committerSven Eckelmann <sven@narfation.org>
Tue, 17 Jul 2018 18:21:06 +0000 (20:21 +0200)
cfg80211 is loaded by kmodloader after the modules with a priority
(AutoLoad) are loaded. batman-adv should therefore also be loaded at that
time and must not load cfg80211 itself. The information in the ELF header
are enough for kmodloader to load these two modules in the correct order.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile

index bf8b94688a484f45a0800597847803f30c5f182e..a665b5db561859c7be04f36bf2db990a350a5493 100644 (file)
@@ -27,7 +27,7 @@ define KernelPackage/batman-adv
   DEPENDS:=+KMOD_BATMAN_ADV_BLA:kmod-lib-crc16 +kmod-crypto-crc32c +kmod-lib-crc32c +kmod-cfg80211
   TITLE:=B.A.T.M.A.N. Adv
   FILES:=$(PKG_BUILD_DIR)/net/batman-adv/batman-adv.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,50,cfg80211 batman-adv)
+  AUTOLOAD:=$(call AutoProbe,batman-adv)
 endef
 
 define KernelPackage/batman-adv/description