openocd: update to 0.11.0-rc1; add libgpiod dep; always depend on USB libs 14411/head
authorPaul Fertser <fercerpav@gmail.com>
Wed, 16 Dec 2020 11:14:15 +0000 (12:14 +0100)
committerPaul Fertser <fercerpav@gmail.com>
Sat, 2 Jan 2021 19:29:19 +0000 (22:29 +0300)
The first release candidate with plenty of changes needs wider testing,
so package it.

Since Linux 4.8 new more efficient GPIO manipulation API is available
and sysfs class gpio is deprecated. Enable OpenOCD support for both for
now to avoid breaking existing user configs.

Due to low user demand and packaging difficulties require USB libraries
unconditionally from now on. Their sizes are not significant compared to
the OpenOCD package itself.

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
utils/openocd/Makefile
utils/openocd/patches/010-gcc10.patch [deleted file]

index 30c2e836855ac6bd4a2bd449681ebacc5cb7c434..2581fe6b5461d68f72005609899db6be3d4fd5b6 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openocd
-PKG_SOURCE_VERSION:=v0.10.0-1000-gdb23c13d
+PKG_SOURCE_VERSION:=v0.11.0-rc1
 PKG_VERSION:=$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://git.code.sf.net/p/openocd/code
-PKG_MIRROR_HASH:=6f8c0ecf240427654ad5e911b44f78996da931209280f4a19c1215802ff14638
+PKG_MIRROR_HASH:=c4a0a6cad821946608c843f557b993e7cfeb0f193e4c0f149ebfbfbfd57054a6
 
 PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=COPYING
@@ -37,18 +37,11 @@ define Package/openocd
   CATEGORY:=Utilities
   TITLE:=OpenOCD Utility
   URL:=http://openocd.sf.net/
-  DEPENDS:=+PACKAGE_openocd_with_usb:libusb-1.0 \
-       +PACKAGE_openocd_with_usb:libusb-compat \
-       +PACKAGE_openocd_with_usb:libftdi1 \
-       +PACKAGE_openocd_with_usb:hidapi
-endef
-
-define Package/openocd/config
-  if PACKAGE_openocd
-       config PACKAGE_openocd_with_usb
-               bool "Build with support for USB adapters."
-               default y
-  endif
+  DEPENDS:=+libusb-1.0 \
+       +libusb-compat \
+       +libftdi1 \
+       +hidapi \
+       +libgpiod
 endef
 
 define Package/openocd/description
@@ -78,9 +71,9 @@ CONFIGURE_ARGS += \
        --prefix="/usr" \
        --disable-werror \
        MAKEINFO=true \
-       $(if $(CONFIG_PACKAGE_openocd_with_usb),,PKG_CONFIG=false) \
        --enable-dummy \
-       --enable-sysfsgpio
+       --enable-sysfsgpio \
+       --enable-linuxgpiod
 
 TARGET_CFLAGS += -DRELSTR=\\\"-$(PKG_VERSION)-$(PKG_RELEASE)-OpenWrt\\\"
 
diff --git a/utils/openocd/patches/010-gcc10.patch b/utils/openocd/patches/010-gcc10.patch
deleted file mode 100644 (file)
index 9bfb610..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From c60252ac2b636c4d99b766a574b9df0966151696 Mon Sep 17 00:00:00 2001
-From: Andreas Fritiofson <andreas.fritiofson@gmail.com>
-Date: Fri, 17 Apr 2020 13:49:28 +0200
-Subject: [PATCH] bitbang: Fix FTBFS with GCC 10
-
-GCC 10 defaults to -fno-common which breaks the sharing of bitbang_swd
-struct between bitbang drivers due to a missing extern.
-
-Change-Id: I2b4122f7939cec91a72284006748f99a23548324
-Signed-off-by: Andreas Fritiofson <andreas.fritiofson@gmail.com>
-Reviewed-on: http://openocd.zylin.com/5592
-Tested-by: jenkins
-Reviewed-by: Antonio Borneo <borneo.antonio@gmail.com>
-Reviewed-by: Jonathan McDowell <noodles-openocd@earth.li>
----
- src/jtag/drivers/bitbang.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/jtag/drivers/bitbang.h b/src/jtag/drivers/bitbang.h
-index edb779c..bbbc693 100644
---- a/src/jtag/drivers/bitbang.h
-+++ b/src/jtag/drivers/bitbang.h
-@@ -57,7 +57,7 @@ struct bitbang_interface {
-       void (*swdio_drive)(bool on);
- };
--const struct swd_driver bitbang_swd;
-+extern const struct swd_driver bitbang_swd;
- extern bool swd_mode;