mvebu: macchiatobin-singleshot: enable heartbeat LED
authorTomasz Maciej Nowak <tmn505@gmail.com>
Fri, 18 Dec 2020 14:46:21 +0000 (15:46 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 19 Dec 2020 23:00:33 +0000 (00:00 +0100)
With board revision 1.3, SolidRun moved the power LED to the middle of
the board. In old place of power LED a GPIO controllable heartbeat LED
was added. This commit touches only Single Shot variant, because all
have revision 1.3. Some boards could be placed in an enclosure, therefore
the LED18 is enabled by default, since that'll be the only visible
indicator that the board is operating.

Ref: http://wiki.macchiatobin.net/tiki-index.php?page=Schematics#Revision1.3_Electrical_Design_Changes
Ref: http://macchiatobin.net/wp-content/uploads/2017/11/MACCHIATOBin-rev-1_3.pdf

Reported-by: Alexandra Alth <alexandra@alth.de>
Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
target/linux/mvebu/image/cortexa72.mk
target/linux/mvebu/patches-5.4/028-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch [new file with mode: 0644]

index 1440c07a0b5f00c71aa53ca76e93ad9dfbbfab1f..8bd4581766c25c7a382a106962e928a755fc881a 100644 (file)
@@ -38,7 +38,7 @@ define Device/marvell_macchiatobin-singleshot
   DEVICE_ALT0_VENDOR := SolidRun
   DEVICE_ALT0_MODEL := Armada 8040 Community Board
   DEVICE_ALT0_VARIANT := Single Shot
-  DEVICE_PACKAGES += kmod-i2c-mux-pca954x
+  DEVICE_PACKAGES += kmod-i2c-mux-pca954x kmod-ledtrig-heartbeat
   DEVICE_DTS := armada-8040-mcbin-singleshot
   SUPPORTED_DEVICES := marvell,armada8040-mcbin-singleshot
 endef
diff --git a/target/linux/mvebu/patches-5.4/028-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch b/target/linux/mvebu/patches-5.4/028-arm64-dts-mcbin-singleshot-add-heartbeat-LED.patch
new file mode 100644 (file)
index 0000000..c3abae6
--- /dev/null
@@ -0,0 +1,65 @@
+From da57203dc7fd556fbb3f0ec7d7d7c0b0e893b386 Mon Sep 17 00:00:00 2001
+From: Tomasz Maciej Nowak <tmn505@gmail.com>
+Date: Tue, 10 Nov 2020 16:38:31 +0100
+Subject: [PATCH] arm64: dts: mcbin-singleshot: add heartbeat LED
+
+With board revision 1.3, SolidRun moved the power LED to the middle of
+the board. In old place of power LED a GPIO controllable heartbeat LED
+was added. This commit only touches Single Shot variant, since only this
+variant is all revision 1.3.
+
+Note:
+This is slightly modified patch. Some boards could be placed in an
+enclosure, so the LED18 is enabled by default, since that'll be the only
+visible indicator that the board is operating.
+
+Reported-by: Alexandra Alth <alexandra@alth.de>
+Signed-off-by: Tomasz Maciej Nowak <tmn505@gmail.com>
+Signed-off-by: Gregory CLEMENT <gregory.clement@bootlin.com>
+---
+ .../marvell/armada-8040-mcbin-singleshot.dts  | 22 +++++++++++++++++++
+ 1 file changed, 22 insertions(+)
+
+--- a/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
++++ b/arch/arm64/boot/dts/marvell/armada-8040-mcbin-singleshot.dts
+@@ -5,6 +5,8 @@
+  * Device Tree file for MACCHIATOBin Armada 8040 community board platform
+  */
++#include <dt-bindings/leds/common.h>
++
+ #include "armada-8040-mcbin.dtsi"
+ / {
+@@ -12,6 +14,20 @@
+       compatible = "marvell,armada8040-mcbin-singleshot",
+                       "marvell,armada8040-mcbin", "marvell,armada8040",
+                       "marvell,armada-ap806-quad", "marvell,armada-ap806";
++
++      leds {
++              compatible = "gpio-leds";
++              pinctrl-0 = <&cp0_led18_pins>;
++              pinctrl-names = "default";
++
++              led18 {
++                      gpios = <&cp0_gpio2 1 GPIO_ACTIVE_LOW>;
++                      function = LED_FUNCTION_HEARTBEAT;
++                      color = <LED_COLOR_ID_GREEN>;
++                      linux,default-trigger = "heartbeat";
++                      default-state = "on";
++              };
++      };
+ };
+ &cp0_eth0 {
+@@ -27,3 +43,10 @@
+       managed = "in-band-status";
+       sfp = <&sfp_eth1>;
+ };
++
++&cp0_pinctrl {
++      cp0_led18_pins: led18-pins {
++              marvell,pins = "mpp33";
++              marvell,function = "gpio";
++      };
++};