hplip: add a patch to respect CFLAGS 16523/head
authorMichal Vasilek <michal.vasilek@nic.cz>
Thu, 2 Sep 2021 13:59:15 +0000 (15:59 +0200)
committerMichal Vasilek <michal.vasilek@nic.cz>
Fri, 3 Sep 2021 08:47:38 +0000 (10:47 +0200)
* fixes build with PIE

Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
utils/hplip/patches/070-respect-cflags.patch [new file with mode: 0644]

diff --git a/utils/hplip/patches/070-respect-cflags.patch b/utils/hplip/patches/070-respect-cflags.patch
new file mode 100644 (file)
index 0000000..c1f7c79
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/configure.in
++++ b/configure.in
+@@ -632,14 +632,14 @@ if test "$class_driver" = "no" && test "
+    fi
+ fi
+-SAVE_CPPFLAGS="$CPPFLAGS"
++SAVE_CFLAGS="$CFLAGS"
+ CFLAGS=`python-config --includes`
+-if [ $? -eq 0 ] 
++if test $? -eq 0
+ then
+    echo $FLAGS
+ else
+ CFLAGS=`python3-config --includes`
+-   if [ $? -eq 0 ]
++   if test $? -eq 0
+    then
+    echo $FLAGS
+    fi
+@@ -659,7 +659,7 @@ if test "$class_driver" = "no" && test "
+    AS_IF([test "x$FOUND_HEADER" != "xyes"],
+           [AC_MSG_ERROR([cannot find python-devel support], 6)])
+ fi
+-CFLAGS="$save_CFLAGS"
++CFLAGS="$SAVE_CFLAGS"
+ if test "$hpijs_only_build" = "no" && test "$scan_build" = "yes" && test "$hpcups_only_build" = "no"; then
+    AC_CHECK_LIB([sane], [sane_open], [LIBS="$LIBS"], [AC_MSG_ERROR([cannot find sane-backends-devel support (or --disable-scan-build)], 12)])