node: update to v12.20.0 14034/head
authorHirokazu MORIKAWA <morikw2@gmail.com>
Thu, 26 Nov 2020 23:58:31 +0000 (08:58 +0900)
committerHirokazu MORIKAWA <morikw2@gmail.com>
Thu, 26 Nov 2020 23:58:31 +0000 (08:58 +0900)
Update to v12.20.0
Take over maintainership from John Crispin

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node/Makefile
lang/node/patches/003-path.patch
lang/node/patches/999-fix_missing_llhttp_depends.patch [deleted file]
lang/node/patches/999-localhost-no-addrconfig.patch

index 947918256d4c059044878dfdf92ad0c701afd8e0..b645b003d1a53c6afdeab52af9d97ad68e948efd 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=node
-PKG_VERSION:=v12.19.0
+PKG_VERSION:=v12.20.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=3b671c45c493f96d7e018c15110cdbafa4478e5e5cfc9e6eec83cea9e6b551e1
+PKG_HASH:=61e3fd5c9af565e8d25403ce56b2c0097e2e3270381f2d4216573d48b3dc428b
 
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>, Adrian Panella <ianchi74@outlook.com>
+PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 PKG_CPE_ID:=cpe:/a:nodejs:node.js
index 8becfa1b6a3acc8450c6ee72b0d7003331565d57..98d0b1eadc0f8acbb6ee860a1c0896a836729788 100644 (file)
@@ -1,6 +1,6 @@
 --- a/lib/internal/modules/cjs/loader.js
 +++ b/lib/internal/modules/cjs/loader.js
-@@ -1117,7 +1117,8 @@
+@@ -1109,7 +1109,8 @@
      path.resolve(process.execPath, '..') :
      path.resolve(process.execPath, '..', '..');
  
diff --git a/lang/node/patches/999-fix_missing_llhttp_depends.patch b/lang/node/patches/999-fix_missing_llhttp_depends.patch
deleted file mode 100644 (file)
index bd6c16f..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN a/node.gypi b/node.gypi
---- a/node.gypi        2019-09-05 00:36:25.000000000 +0900
-+++ b/node.gypi        2019-09-13 09:57:54.073191914 +0900
-@@ -149,6 +149,10 @@
-         'deps/http_parser/http_parser.gyp:http_parser',
-         'deps/llhttp/llhttp.gyp:llhttp'
-       ],
-+    }, {
-+      'dependencies': [
-+        'deps/llhttp/llhttp.gyp:llhttp'
-+      ],
-     } ],
-     [ 'node_shared_cares=="false"', {
index d07d5b8145c6b83184637950fdd0342b34f22395..4d11973216c057d603a587024e877edeb34f651f 100644 (file)
@@ -13,7 +13,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
  //
  // Permission is hereby granted, free of charge, to any person obtaining a
  // copy of this software and associated documentation files (the
-@@ -1029,13 +1030,6 @@
+@@ -1028,13 +1029,6 @@
      hints: options.hints || 0
    };