linuxptp: pass TARGET_CFLAGS using MAKE_VARS, bump PKG_RELEASE 2943/head
authorStephen Walker <stephendwalker+github@gmail.com>
Tue, 19 Jul 2016 23:02:02 +0000 (19:02 -0400)
committerStephen Walker <stephendwalker+github@gmail.com>
Tue, 19 Jul 2016 23:02:02 +0000 (19:02 -0400)
ccache_cc -Wall -DVER=1.6  -D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC     -c -o ptp4l.o ptp4l.c
cc1: note: someone does not honour COPTS correctly, passed 0 times

unpatched
  8229 hwstamp_ctl
128213 phc2sys
 37045 phc_ctl
 99077 pmc
185589 ptp4l
 41141 timemaster

patched (honouring -Os CFLAG)
  8213 hwstamp_ctl
 54469 phc2sys
 20645 phc_ctl
 49877 pmc
 74965 ptp4l
 20645 timemaster

Signed-off-by: Stephen Walker <stephendwalker+github@gmail.com>
net/linuxptp/Makefile

index 9bc881da9754a4f1f1a8ed5c93f4cd6842917a87..88edd155aaa4f69258c69b9ddc319add6daa12b8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linuxptp
 PKG_VERSION:=20151118
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_REV:=999c86f4a9da4bf4508b3a69289f58166ed18a55
 
 PKG_MAINTAINER:=Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
@@ -41,6 +41,9 @@ define Package/linuxptp/description
  computers.
 endef
 
+MAKE_VARS += \
+       EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)"
+
 define Package/linuxptp/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hwstamp_ctl $(1)/usr/sbin/