rockchip: use downstream GPIO button implementation
authorDavid Bauer <mail@david-bauer.net>
Mon, 13 Jul 2020 15:44:07 +0000 (17:44 +0200)
committerDavid Bauer <mail@david-bauer.net>
Mon, 13 Jul 2020 15:50:35 +0000 (17:50 +0200)
Use the OpenWrt netlink GPIO button implementation to forward button
presses to procd. This is necessary to make failsafe-mode access
using a button possible.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/rockchip/Makefile
target/linux/rockchip/armv8/config-5.4

index 41f0560bacbd7a99dc67c68938236c43698fee16..8daaad34a7412c1d014df141b476f896e55525f8 100644 (file)
@@ -17,7 +17,7 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs
+DEFAULT_PACKAGES += uboot-envtools partx-utils e2fsprogs mkf2fs kmod-gpio-button-hotplug
 
 KERNELNAME:=Image dtbs
 
index 48b05b432bd53ad142ca5c8edd0800887233eada..2d2342e34f71512efa04f6b3c34534b89c0280c8 100644 (file)
@@ -221,7 +221,6 @@ CONFIG_KALLSYMS=y
 CONFIG_KEXEC_CORE=y
 CONFIG_KEXEC_FILE=y
 # CONFIG_KEXEC_SIG is not set
-CONFIG_KEYBOARD_GPIO=y
 CONFIG_KSM=y
 # CONFIG_LEDS_BRIGHTNESS_HW_CHANGED is not set
 CONFIG_LEDS_GPIO=y