curl: update to 7.86.0 19745/head
authorStan Grishin <stangri@melmac.ca>
Sun, 30 Oct 2022 19:25:20 +0000 (19:25 +0000)
committerStan Grishin <stangri@melmac.ca>
Sun, 30 Oct 2022 19:54:05 +0000 (19:54 +0000)
* update to 7.86.0: https://curl.se/changes.html#7_86_0
* remove 300-curl-wolfssl.m4-error-out-if-wolfSSL-is-not-usable.patch as
  it was fixed upstream: https://github.com/curl/curl/pull/9682
* update configure options for OpenSSL as --without-ssl is breaking build
* remove --without-libidn configure arg as it's no longer recognized

Signed-off-by: Stan Grishin <stangri@melmac.ca>
net/curl/Makefile
net/curl/patches/300-curl-wolfssl.m4-error-out-if-wolfSSL-is-not-usable.patch [deleted file]

index 6d0c4848489ce04032eb721a583dee8521a1ffb3..1ea2948e7facb476ff954e5b2a41494e5731dbde 100644 (file)
@@ -8,15 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.85.0
-PKG_RELEASE:=$(AUTORELEASE).1
+PKG_VERSION:=7.86.0
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/curl/curl/releases/download/curl-$(subst .,_,$(PKG_VERSION))/ \
        https://dl.uxnr.de/mirror/curl/ \
        https://curl.askapache.com/download/ \
        https://curl.se/download/
-PKG_HASH:=88b54a6d4b9a48cb4d873c7056dcba997ddd5b7be5a2d537a4acb55c20b04be6
+PKG_HASH:=2d61116e5f485581f6d59865377df4463f2e788677ac43222b496d4e49fb627b
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -116,7 +116,6 @@ CONFIGURE_ARGS += \
        --disable-manual \
        --without-nss \
        --without-librtmp \
-       --without-libidn \
        --without-ca-path \
        --without-libpsl \
        --without-zstd \
@@ -126,7 +125,7 @@ CONFIGURE_ARGS += \
        \
        $(if $(CONFIG_LIBCURL_WOLFSSL),--with-wolfssl="$(STAGING_DIR)/usr",--without-wolfssl) \
        $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
-       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ssl="$(STAGING_DIR)/usr",--without-ssl) \
+       $(if $(CONFIG_LIBCURL_OPENSSL),--with-openssl="$(STAGING_DIR)/usr",--without-openssl) \
        $(if $(CONFIG_LIBCURL_MBEDTLS),--with-mbedtls="$(STAGING_DIR)/usr",--without-mbedtls) \
        \
        $(if $(CONFIG_LIBCURL_LIBIDN2),--with-libidn2="$(STAGING_DIR)/usr",--without-libidn2) \
diff --git a/net/curl/patches/300-curl-wolfssl.m4-error-out-if-wolfSSL-is-not-usable.patch b/net/curl/patches/300-curl-wolfssl.m4-error-out-if-wolfSSL-is-not-usable.patch
deleted file mode 100644 (file)
index 3edb84d..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-From 5c91ff8853cbe08fb30462f99d3261383de9b98e Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Mon, 10 Oct 2022 07:36:56 +0200
-Subject: [PATCH] curl-wolfssl.m4: error out if wolfSSL is not usable
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-When I explicitly declare, that I would like to have curl built with
-wolfSSL support using `--with-wolfssl` configure option, then I would
-expect, that either I endup with curl having that support, for example
-in form of https support or it wouldn't be available at all.
-
-Downstream projects like for example OpenWrt build curl wolfSSL variant
-with `--with-wolfssl` already, but in certain corner cases it does fail:
-
-  configure:25299: checking for wolfSSL_Init in -lwolfssl
-  configure:25321: x86_64-openwrt-linux-musl-gcc -o conftest [snip]
-  In file included from target-x86_64_musl/usr/include/wolfssl/wolfcrypt/dsa.h:33,
-                   from target-x86_64_musl/usr/include/wolfssl/wolfcrypt/asn_public.h:35,
-                  from target-x86_64_musl/usr/include/wolfssl/ssl.h:35,
-                   from conftest.c:47:
-  target-x86_64_musl/usr/include/wolfssl/wolfcrypt/integer.h:37:14: fatal error: wolfssl/wolfcrypt/sp_int.h: No such file or directory
-       #include <wolfssl/wolfcrypt/sp_int.h>
-                ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
-  compilation terminated.
-
-and in the end thus produces curl without https support:
-
- curl: (1) Protocol "https" not supported or disabled in libcurl
-
-So fix it, by making the working wolfSSL mandatory and error out in
-configure step when that's not the case:
-
- checking for wolfSSL_Init in -lwolfssl... no
- configure: error: --with-wolfssl but wolfSSL was not found or doesn't work
-
-References: https://github.com/openwrt/packages/issues/19005
-References: https://github.com/openwrt/packages/issues/19547
-Upstream-Status: Accepted [https://github.com/curl/curl/pull/9682]
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
----
- m4/curl-wolfssl.m4 | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
---- a/m4/curl-wolfssl.m4
-+++ b/m4/curl-wolfssl.m4
-@@ -154,7 +154,8 @@ if test "x$OPT_WOLFSSL" != xno; then
-           AC_MSG_NOTICE([Added $wolfssllibpath to CURL_LIBRARY_PATH])
-         fi
-       fi
--
-+    else
-+        AC_MSG_ERROR([--with-wolfssl but wolfSSL was not found or doesn't work])
-     fi
-   fi dnl wolfSSL not disabled