opendoas: avoid libpam dependency
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 15 Sep 2022 00:21:50 +0000 (21:21 -0300)
committerRosen Penev <rosenp@gmail.com>
Thu, 22 Sep 2022 08:22:28 +0000 (01:22 -0700)
Package is failing to build because it picks up libpam dependency
regardless of `BUSYBOX_CONFIG_PAM`.

Use configure args --with-pam, --without-pam to assert the option.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
utils/opendoas/Makefile

index 78f962f3b61f85089fa518e5e68073644efb9b7d..23882d521d3fe6dae86f8be3bcd411933000be69 100644 (file)
@@ -33,6 +33,8 @@ define Package/opendoas/description
  of sudo with a fraction of the codebase.
 endef
 
+CONFIGURE_ARGS += $(if $(CONFIG_BUSYBOX_CONFIG_PAM),--with,--without)-pam
+
 define Package/opendoas/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/doas $(1)/usr/bin/