librsocket-cpp: Update to 2019-10-07
authorRosen Penev <rosenp@gmail.com>
Mon, 7 Oct 2019 17:50:41 +0000 (10:50 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 7 Oct 2019 17:59:59 +0000 (10:59 -0700)
Added patch to remove boost-thread dependency.

Added size optimizations.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/librsocket-cpp/Makefile
libs/librsocket-cpp/patches/103-boost.patch [deleted file]
libs/librsocket-cpp/patches/103-no-boost-thread.patch [new file with mode: 0644]

index 865addf15e9801bdde1e529202b5bff489d75f3a..45459978f579e461b5633d91a3e03ce3a4912103 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=librsocket-cpp
-PKG_SOURCE_DATE:=2019-09-22
-PKG_SOURCE_VERSION:=b268907312af589828634c143b9f35b58cd6cfea
+PKG_SOURCE_DATE:=2019-10-07
+PKG_SOURCE_VERSION:=0a469f7a84d9e3c3ddcb6931df701a5dae536589
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_DATE).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/rsocket/rsocket-cpp/tar.gz/$(PKG_SOURCE_VERSION)?
-PKG_HASH:=7ab4655d3d8148ce689f74a116ae7393d9e802f91d0dfd697ffd8daeff800e61
+PKG_HASH:=c10e498039d676946a11f6a45201575cdb3f1f582752693d7b1901aa434f3146
 PKG_BUILD_DIR:=$(BUILD_DIR)/rsocket-cpp-$(PKG_SOURCE_VERSION)
 
 PKG_MAINTAINER:=Amol Bhave <ambhave@fb.com>
@@ -48,8 +48,22 @@ endef
 CMAKE_OPTIONS += \
        -DBUILD_BENCHMARKS=OFF \
        -DBUILD_EXAMPLES=OFF \
+       -DBUILD_SHARED_LIBS=ON \
        -DBUILD_TESTS=OFF \
        -DCMAKE_POSITION_INDEPENDENT_CODE=ON
 
+TARGET_CXXFLAGS += -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+
+define Package/librsocket-cpp/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libReactiveSocket.so* $(1)/usr/lib/
+endef
+
+define Package/libyarpl/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libyarpl*.so* $(1)/usr/lib/
+endef
+
 $(eval $(call BuildPackage,librsocket-cpp))
 $(eval $(call BuildPackage,libyarpl))
diff --git a/libs/librsocket-cpp/patches/103-boost.patch b/libs/librsocket-cpp/patches/103-boost.patch
deleted file mode 100644 (file)
index 40737f0..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -194,6 +194,9 @@ find_package(Gflags REQUIRED)
- # find glog::glog to satisfy the folly dep.
- find_package(Glog REQUIRED)
-+find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
-+                                       date_time program_options)
-+
- include_directories(SYSTEM ${OPENSSL_INCLUDE_DIR})
- include_directories(SYSTEM ${GFLAGS_INCLUDE_DIR})
diff --git a/libs/librsocket-cpp/patches/103-no-boost-thread.patch b/libs/librsocket-cpp/patches/103-no-boost-thread.patch
new file mode 100644 (file)
index 0000000..60a3f34
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -195,7 +195,7 @@ find_package(Gflags REQUIRED)
+ find_package(Glog REQUIRED)
+ # find boost::* to satisfy the folly dep
+-find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
++find_package(Boost REQUIRED COMPONENTS system filesystem regex context
+                                        program_options)
+ include_directories(SYSTEM ${OPENSSL_INCLUDE_DIR})