Add a pgsql-cli subpackage, extend help in Config.in, standardize Makefile
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 15:51:19 +0000 (15:51 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Jun 2005 15:51:19 +0000 (15:51 +0000)
SVN-Revision: 1184

openwrt/package/postgresql/Config.in
openwrt/package/postgresql/Makefile
openwrt/package/postgresql/ipkg/pgsql-cli.control [new file with mode: 0644]

index 542f3d44a97099b30bee93b2b60534781b70224e..3a2dc6c7b2da88fc3aa9bef7e7419def2bacbf04 100644 (file)
@@ -9,8 +9,53 @@ config BR2_PACKAGE_LIBPQ
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_POSTGRESQL
        help
-         PostgreSQL client library.
+         PostgreSQL is an object-relational database management system (ORDBMS) 
+         based on POSTGRES, Version 4.2, developed at the University of 
+         California at Berkeley Computer Science Department. POSTGRES pioneered 
+         many concepts that only became available in some commercial database 
+         systems much later.
+
+         PostgreSQL is an open-source descendant of this original Berkeley code. 
+         It supports SQL92 and SQL99 and offers many modern features:
+
+           * complex queries
+           * foreign keys
+           * triggers
+           * views
+           * transactional integrity
+           * multiversion concurrency control
+         
+         http://www.postgresql.org/
+         
+         This package contains the shared client library, needed by other programs.
+
+config BR2_PACKAGE_PGSQL_CLI
+       prompt "pgsql-cli - Command Line Interface (CLI) to PostgreSQL databases"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_LIBPQ
+       help
+         PostgreSQL is an object-relational database management system (ORDBMS) 
+         based on POSTGRES, Version 4.2, developed at the University of 
+         California at Berkeley Computer Science Department. POSTGRES pioneered 
+         many concepts that only became available in some commercial database 
+         systems much later.
+
+         PostgreSQL is an open-source descendant of this original Berkeley code. 
+         It supports SQL92 and SQL99 and offers many modern features:
+
+           * complex queries
+           * foreign keys
+           * triggers
+           * views
+           * transactional integrity
+           * multiversion concurrency control
          
          http://www.postgresql.org/
          
+         This package contains a terminal-based front-end to PostgreSQL. It enables 
+         you to type in queries interactively, issue them to PostgreSQL, and see the 
+         query results.  Alternatively, input can be from a file. In addition, it 
+         provides a number of  meta-commands  and  various  shell-like features to 
+         facilitate writing scripts and automating a wide variety of tasks.
 
index cadbcea14c0c3d5d7294565ee93db4e5c8f2b010..de021ba35b23fcfcffe8c69f7eee79a2b3e33564 100644 (file)
@@ -21,6 +21,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBPQ,libpq,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,PGSQL_CLI,pgsql-cli,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
 #      ./configure advertise "--infodir", but does not support it, replaced with "--docdir"
@@ -75,14 +76,23 @@ $(PKG_BUILD_DIR)/.built:
        $(MAKE) -C "$(PKG_BUILD_DIR)/src/interfaces/libpq" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
+       $(MAKE) -C "$(PKG_BUILD_DIR)/src/bin/psql" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
        touch $@
 
-$(IPKG_LIBPQ): $(STAGING_DIR)/usr/lib/libpq.so
+$(IPKG_LIBPQ):
        install -d -m0755 $(IDIR_LIBPQ)/usr/lib
-       cp -fpR $(STAGING_DIR)/usr/lib/libpq.so.* $(IDIR_LIBPQ)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libpq.so.* $(IDIR_LIBPQ)/usr/lib/
        $(RSTRIP) $(IDIR_LIBPQ)
        $(IPKG_BUILD) $(IDIR_LIBPQ) $(PACKAGE_DIR)
 
+$(IPKG_PGSQL_CLI):
+       install -d -m0755 $(IDIR_PGSQL_CLI)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/psql $(IDIR_PGSQL_CLI)/usr/bin/
+       $(RSTRIP) $(IDIR_PGSQL_CLI)
+       $(IPKG_BUILD) $(IDIR_PGSQL_CLI) $(PACKAGE_DIR)
+
 $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
@@ -90,16 +100,16 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
        cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
        cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libpq.{a,so*} $(STAGING_DIR)/usr/lib/
-       touch $(STAGING_DIR)/usr/lib/libpq.so
+       touch $@
 
 install-dev: $(STAGING_DIR)/usr/lib/libpq.so
 
 uninstall-dev:
        rm -rf \
-         $(STAGING_DIR)/usr/include/libpq-fe.h \
-         $(STAGING_DIR)/usr/include/postgres_ext.h \
-         $(STAGING_DIR)/usr/include/postgresql \
-         $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
+               $(STAGING_DIR)/usr/include/libpq-fe.h \
+               $(STAGING_DIR)/usr/include/postgres_ext.h \
+               $(STAGING_DIR)/usr/include/postgresql \
+               $(STAGING_DIR)/usr/lib/libpq.{a,so*} \
 
 compile: install-dev
 clean: uninstall-dev
diff --git a/openwrt/package/postgresql/ipkg/pgsql-cli.control b/openwrt/package/postgresql/ipkg/pgsql-cli.control
new file mode 100644 (file)
index 0000000..e83aa7b
--- /dev/null
@@ -0,0 +1,8 @@
+Package: pgsql-cli
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/postgresql/
+Description: Command Line Interface (CLI) to PostgreSQL databases