tiff: add a tiff-utils subpackage
authorNicolas Thill <nico@openwrt.org>
Thu, 16 Jul 2009 06:22:37 +0000 (06:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 16 Jul 2009 06:22:37 +0000 (06:22 +0000)
SVN-Revision: 16855

libs/tiff/Makefile

index 0e1fc25ae64ea94f7b387e967039894346e2f80a..6e9e0cd03a1a634af79f34fcdd987662f9f156c6 100644 (file)
@@ -21,13 +21,27 @@ include $(INCLUDE_DIR)/package.mk
 
 PKG_INSTALL=1
 
+define Package/tiff/Default
+  TITLE:=TIFF
+  URL:=http://www.remotesensing.org/libtiff/
+endef
+
 define Package/libtiff
+$(call Package/tiff/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=TIFF libraries
+  TITLE+= libraries
   DEPENDS:=+zlib +libjpeg
 endef
 
+define Package/tiff-utils
+$(call Package/tiff/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= utilities
+  DEPENDS:=+libtiff
+endef
+
 TARGET_CFLAGS += $(FPIC)
 
 CONFIGURE_ARGS += --without-x
@@ -43,4 +57,10 @@ define Package/libtiff/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
 endef
 
+define Package/tiff-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
 $(eval $(call BuildPackage,libtiff))
+$(eval $(call BuildPackage,tiff-utils))