pciutils: use new pciids package 14362/head
authorRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 05:02:30 +0000 (21:02 -0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 30 Dec 2020 05:24:08 +0000 (21:24 -0800)
Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
utils/pciutils/Makefile
utils/pciutils/patches/101-no-strip.patch
utils/pciutils/patches/102-compressed-ids.patch
utils/pciutils/patches/106-hwdata.patch [new file with mode: 0644]

index 25aa105c512615809da9d77153ac423638f614e0..84b8998fa09463a4b78837cd6f210e146b070579 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pciutils
 PKG_VERSION:=3.7.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/utils/pciutils
@@ -29,7 +29,7 @@ define Package/pciutils
   CATEGORY:=Utilities
   TITLE:=Linux PCI Utilities
   URL:=http://mj.ucw.cz/pciutils.shtml
-  DEPENDS:=+libkmod +libpci
+  DEPENDS:=+libkmod +libpci +pciids
 endef
 
 define Package/pciutils/description
@@ -44,23 +44,6 @@ define Package/libpci
   URL:=http://mj.ucw.cz/pciutils.shtml
 endef
 
-
-PCI_IDS_VER:=0.336
-PCI_IDS_FILE:=pci.ids.$(PCI_IDS_VER)
-define Download/pci_ids
-  FILE:=$(PCI_IDS_FILE)
-  URL_FILE:=pci.ids
-  URL:=@GITHUB/vcrhonek/hwdata/v$(PCI_IDS_VER)
-  HASH:=94053616c1f9b93540861931fb7891b1b30d6fd21b3e2c1647467527ea38f557
-endef
-$(eval $(call Download,pci_ids))
-
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       $(RM) $(PKG_BUILD_DIR)/pci.ids
-       $(CP) $(DL_DIR)/$(PCI_IDS_FILE) $(PKG_BUILD_DIR)/pci.ids
-endef
-
 TARGET_CFLAGS += $(FPIC)
 
 MAKE_FLAGS += \
@@ -92,8 +75,6 @@ endef
 define Package/pciutils/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{lspci,setpci,update-pciids} $(1)/usr/sbin/
-       $(INSTALL_DIR) $(1)/usr/share
-       $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/pci.ids $(1)/usr/share/
 endef
 
 define Package/libpci/install
index c3935a001dd6a32bc5427a51d8e82a4fbd9f7aad..2f1e022893c56676d525b59b27e5c00190053475 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -119,7 +119,7 @@
+@@ -119,7 +119,7 @@ distclean: clean
  install: all
  # -c is ignored on Linux, but required on FreeBSD
        $(DIRINSTALL) -m 755 $(DESTDIR)$(SBINDIR) $(DESTDIR)$(IDSDIR) $(DESTDIR)$(MANDIR)/man8 $(DESTDIR)$(MANDIR)/man7 $(DESTDIR)/$(MANDIR)/man5
index 9b319384587a07ce483211be06575f7c1d5c2440..2ea8605d9dc0bc67354e20fe5b8733c7c503edef 100644 (file)
@@ -1,7 +1,7 @@
 --- a/update-pciids.sh
 +++ b/update-pciids.sh
 @@ -6,9 +6,8 @@ set -e
- SRC="http://pci-ids.ucw.cz/v2.2/pci.ids"
+ SRC="https://pci-ids.ucw.cz/v2.2/pci.ids"
  DEST=pci.ids
  PCI_COMPRESSED_IDS=
 -GREP=grep
diff --git a/utils/pciutils/patches/106-hwdata.patch b/utils/pciutils/patches/106-hwdata.patch
new file mode 100644 (file)
index 0000000..ee63bc5
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -35,7 +35,7 @@ ABI_VERSION=.3
+ PREFIX=/usr/local
+ SBINDIR=$(PREFIX)/sbin
+ SHAREDIR=$(PREFIX)/share
+-IDSDIR=$(SHAREDIR)
++IDSDIR=$(SHAREDIR)/hwdata
+ MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
+ INCDIR=$(PREFIX)/include
+ LIBDIR=$(PREFIX)/lib