ifeq ($(LINUX_VERSION),3.2.16)
LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
endif
-ifeq ($(LINUX_VERSION),3.3.2)
- LINUX_KERNEL_MD5SUM:=cb5f959dfb3009bcc2a6e4ebf162174e
+ifeq ($(LINUX_VERSION),3.3.3)
+ LINUX_KERNEL_MD5SUM:=a6897310b4785b5f912c567cdc93402e
endif
# disable the md5sum check for unknown kernel versions
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
SUBTARGETS:=generic nand
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
SUBTARGETS:=9g20 9260 9263
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
--- a/arch/arm/mach-at91/Kconfig
+++ b/arch/arm/mach-at91/Kconfig
-@@ -318,6 +318,12 @@ config MACH_NEOCORE926
+@@ -335,6 +335,12 @@ config MACH_NEOCORE926
help
Select this if you are using the Adeneo Neocore 926 board.
# ----------------------------------------------------------
--- a/arch/arm/mach-at91/Makefile
+++ b/arch/arm/mach-at91/Makefile
-@@ -56,6 +56,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
+@@ -58,6 +58,7 @@ obj-$(CONFIG_MACH_AT91SAM9G10EK) += boar
obj-$(CONFIG_MACH_AT91SAM9263EK) += board-sam9263ek.o
- obj-$(CONFIG_MACH_USB_A9263) += board-usb-a9263.o
+ obj-$(CONFIG_MACH_USB_A9263) += board-usb-a926x.o
obj-$(CONFIG_MACH_NEOCORE926) += board-neocore926.o
+obj-$(CONFIG_MACH_TQMA9263) += board-tqma9263.o
--- a/arch/arm/mach-at91/at91sam9260_devices.c
+++ b/arch/arm/mach-at91/at91sam9260_devices.c
-@@ -571,7 +571,7 @@ static struct platform_device at91sam926
+@@ -579,7 +579,7 @@ static struct platform_device at91sam926
.num_resources = ARRAY_SIZE(spi1_resources),
};
-Index: linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c
-===================================================================
---- linux-2.6.37.6.orig/arch/arm/mach-at91/board-flexibity.c 2011-05-07 10:07:03.112684983 +0100
-+++ linux-2.6.37.6/arch/arm/mach-at91/board-flexibity.c 2011-05-07 10:07:33.480684982 +0100
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
@@ -1,7 +1,7 @@
/*
* linux/arch/arm/mach-at91/board-flexibity.c
* Copyright (C) 2005 SAN People
* Copyright (C) 2006 Atmel
*
-@@ -65,6 +65,13 @@
- .pullup_pin = 0, /* pull-up driven by UDC */
+@@ -62,6 +62,13 @@ static struct at91_udc_data __initdata f
+ .pullup_pin = -EINVAL, /* pull-up driven by UDC */
};
+/* I2C devices */
/* SPI devices */
static struct spi_board_info flexibity_spi_devices[] = {
{ /* DataFlash chip */
-@@ -143,6 +150,9 @@
+@@ -141,6 +148,9 @@ static void __init flexibity_board_init(
at91_add_device_usbh(&flexibity_usbh_data);
/* USB Device */
at91_add_device_udc(&flexibity_udc_data);
-Index: linux-2.6.39/arch/arm/mach-at91/board-flexibity.c
-===================================================================
---- linux-2.6.39.orig/arch/arm/mach-at91/board-flexibity.c 2011-06-17 11:02:11.335016002 +0100
-+++ linux-2.6.39/arch/arm/mach-at91/board-flexibity.c 2011-06-17 11:02:20.395016002 +0100
-@@ -96,49 +96,49 @@
+--- a/arch/arm/mach-at91/board-flexibity.c
++++ b/arch/arm/mach-at91/board-flexibity.c
+@@ -94,49 +94,49 @@ static struct gpio_led flexibity_leds[]
.name = "usb1:green",
.gpio = AT91_PIN_PA12,
.active_low = 1,
FEATURES:=squashfs
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs broken
CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
{
u16 cmd;
-@@ -894,3 +896,5 @@ static void __devinit quirk_usb_early_ha
+@@ -898,3 +900,5 @@ static void __devinit quirk_usb_early_ha
pci_disable_device(pdev);
}
DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
INITRAMFS_EXTRA_FILES:=
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
FEATURES:=targz ext4
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
FEATURES:=squashfs
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES+=\
FEATURES:=ext4 audio
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
include $(INCLUDE_DIR)/target.mk
--- a/lib/Kconfig
+++ b/lib/Kconfig
-@@ -98,7 +98,7 @@ config ZLIB_INFLATE
+@@ -108,7 +108,7 @@ config ZLIB_INFLATE
tristate
config ZLIB_DEFLATE
-LINUX_VERSION:=3.3.2
+LINUX_VERSION:=3.3.3
BOARDNAME:=Traverse Geos
FEATURES:=squashfs jffs2 ext4 pci usb gpio
DEFAULT_PACKAGES += \