django: move django* packages under django submenu
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Tue, 9 Jul 2019 12:12:06 +0000 (09:12 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Mon, 12 Aug 2019 12:06:53 +0000 (09:06 -0300)
This changes the python[3]-django dependencies in packages to be
non-selecting, and adds an MDEPENDS line so that the *-src packages get
placed inside the django menu as well.

Added MENU:= to the src-package definitions in python[3]-package.mk,
so it does not import that setting from the binary package.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
15 files changed:
lang/python/django-appconf/Makefile
lang/python/django-compressor/Makefile
lang/python/django-constance/Makefile
lang/python/django-formtools/Makefile
lang/python/django-jsonfield/Makefile
lang/python/django-picklefield/Makefile
lang/python/django-postoffice/Makefile
lang/python/django-ranged-response/Makefile
lang/python/django-restframework/Makefile
lang/python/django-simple-captcha/Makefile
lang/python/django-statici18n/Makefile
lang/python/django-webpack-loader/Makefile
lang/python/django/Makefile
lang/python/python-package.mk
lang/python/python3-package.mk

index e37f15848e85fe7e0a72527b8fe4241398f65a4b..8e81051e1cc7100a242998d296c7484072e1b802 100644 (file)
@@ -39,8 +39,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -51,8 +52,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index a4c9c4e093f8e6e083aa5a4120314f388a9448aa..6638bae69a59160a54e7c0de490678b7842570c2 100644 (file)
@@ -39,10 +39,11 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django \
+       python-django \
        +PACKAGE_python-$(PKG_NAME):python-django-appconf \
        +PACKAGE_python-$(PKG_NAME):python-rcssmin
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -56,10 +57,11 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django \
+       python3-django \
        +PACKAGE_python3-$(PKG_NAME):python3-django-appconf \
        +PACKAGE_python3-$(PKG_NAME):python3-rcssmin
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 7a225acb7a5a442a2b0e952e9434a72197a7bd59..749c0aae1b2d6d15df0129dd060ffdf47e481752 100644 (file)
@@ -37,8 +37,9 @@ define Package/python-django-constance
 $(call Package/python-django-constance/Default)
   DEPENDS:= \
        +PACKAGE_python-django-constance:python \
-       +PACKAGE_python-django-constance:python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-django-constance/description
@@ -49,8 +50,9 @@ define Package/python3-django-constance
 $(call Package/python-django-constance/Default)
   DEPENDS:= \
        +PACKAGE_python3-django-constance:python3 \
-       +PACKAGE_python3-django-constance:python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-django-constance/description
index 4057bc687cbc5d3366e221d4fc8c07e46246fbcf..445cd344623ae274832d54e66bc1449d47c0eba8 100644 (file)
@@ -37,8 +37,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -50,8 +51,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index ed3ffbcebc90b50a6310144bf0d9022861e5a6e4..9e95d3a98cae9915a275bdb0d832580b70169e71 100644 (file)
@@ -39,8 +39,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -51,8 +52,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index b24157b27945ef2f5c91d9255f96136670a45db2..9a7331fc494b48da8336a7d851539069ef74a977 100644 (file)
@@ -39,8 +39,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -51,8 +52,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 0a0a6f1671ee480ac07fdde89e1142bbe5567ca0..cd8ea3dbec9bbf130f95521f2d9feb71b5b253ba 100644 (file)
@@ -39,9 +39,10 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django \
+       python-django \
        +PACKAGE_python-$(PKG_NAME):python-django-jsonfield
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -53,9 +54,10 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django \
+       python3-django \
        +PACKAGE_python3-$(PKG_NAME):python3-django-jsonfield
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 818530f5992b4401c9d3a2e8715bda5eae58e77b..923f5c75b2d4ee6edfac1b69d003d34db7be1dea 100644 (file)
@@ -37,8 +37,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -49,8 +50,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index b699c4857b1a08c177392c920a97ff9b57047457..45c8d7e1ffe2f8d488f0ed9861cddf063ac260bf 100644 (file)
@@ -39,8 +39,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -51,8 +52,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 81d94d9eef4e788cb0b9541b10698b26e7f457f6..20b488ce81374bf1e57853aa358f1882bfe7c147 100644 (file)
@@ -40,10 +40,11 @@ $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
        +PACKAGE_python-$(PKG_NAME):python-six \
-       +PACKAGE_python-$(PKG_NAME):python-django \
+       python-django \
        +PACKAGE_python-$(PKG_NAME):python-pillow \
        +PACKAGE_python-$(PKG_NAME):python-django-ranged-response
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -56,10 +57,11 @@ $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
        +PACKAGE_python3-$(PKG_NAME):python3-six \
-       +PACKAGE_python3-$(PKG_NAME):python3-django \
+       python3-django \
        +PACKAGE_python3-$(PKG_NAME):python3-pillow \
        +PACKAGE_python3-$(PKG_NAME):python3-django-ranged-response
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 97a880596178dbcbc501572f7f368e6a06765313..37f0735348146b36b6f9b407bf67496d7b44e0fa 100644 (file)
@@ -39,8 +39,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -51,8 +52,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index 5186ed946cf8d87bb10f46cc9f312b46e580a27e..72ed867999f478dec4694a9dfdb7cce06e0cd53d 100644 (file)
@@ -37,8 +37,9 @@ define Package/python-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python-$(PKG_NAME):python \
-       +PACKAGE_python-$(PKG_NAME):python-django
+       python-django
   VARIANT:=python
+  MDEPENDS:=python-django
 endef
 
 define Package/python-$(PKG_NAME)/description
@@ -49,8 +50,9 @@ define Package/python3-$(PKG_NAME)
 $(call Package/$(PKG_NAME)/Default)
   DEPENDS:= \
        +PACKAGE_python3-$(PKG_NAME):python3 \
-       +PACKAGE_python3-$(PKG_NAME):python3-django
+       python3-django
   VARIANT:=python3
+  MDEPENDS:=python3-django
 endef
 
 define Package/python3-$(PKG_NAME)/description
index f280d3fca718df6d4696b16517ec635482d02b8d..3c51c7c21bdf6006532d9b5b1299fa66311842c5 100644 (file)
@@ -35,6 +35,7 @@ define Package/django/Default
   CATEGORY:=Languages
   TITLE:=The web framework for perfectionists with deadlines.
   URL:=https://www.djangoproject.com/
+  MENU:=1
 endef
 
 define Package/python-django
index 272aae44fc6949372a98ec03a26c9403cfa5fc45..9bd0b9aa4baf1d86412d0f72aabe2148e64e90be 100644 (file)
@@ -45,6 +45,7 @@ define PyPackage
     EXTRA_DEPENDS:=
     TITLE+= (sources)
     USERID:=
+    MENU:=
   endef
 
   define Package/$(1)-src/description
index 6e163e099d907fcf6918d49c8aba6878eff1a008..e14290081c6ef1767dc3a9846e7cd0ca6fa3cfa2 100644 (file)
@@ -44,6 +44,7 @@ define Py3Package
     EXTRA_DEPENDS:=
     TITLE+= (sources)
     USERID:=
+    MENU:=
   endef
 
   define Package/$(1)-src/description