libgpg-error: Update to 1.36 8549/head
authorRosen Penev <rosenp@gmail.com>
Sun, 31 Mar 2019 09:18:17 +0000 (02:18 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 31 Mar 2019 09:22:34 +0000 (02:22 -0700)
Updated patch to fix compilation on mips64.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libgpg-error/Makefile
libs/libgpg-error/patches/001-cross-compile-fix.patch

index 61db49373c21fb52745a051a6e4d360043553b6a..095526b1ff539b6f5654e250108f581c45990b1f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgpg-error
-PKG_VERSION:=1.34
+PKG_VERSION:=1.36
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://ftp.bit.nl/mirror/gnupg/ \
                https://ftp.nluug.nl/security/gnupg/ \
                http://ring.ksc.gr.jp/archives/net/gnupg/libgpg-error/ \
                https://www.gnupg.org/ftp/gcrypt/libgpg-error/
-PKG_HASH:=0680799dee71b86b2f435efb825391eb040ce2704b057f6bd3dcc47fbc398c81
+PKG_HASH:=babd98437208c163175c29453f8681094bcaf92968a15cafb1a276076b33c97c
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 PKG_LICENSE:=LGPL-2.1+
index c7ff30fae387048f912c9ab3d9c4ba7ed5942ce9..606cdd3785856362f0356d94f022cdafafc1f21a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -74,6 +74,18 @@ AM_SILENT_RULES
+@@ -74,6 +74,21 @@ AM_SILENT_RULES
  AC_CANONICAL_HOST
  AB_INIT
  
@@ -11,6 +11,9 @@
 +    arm-openwrt-linux-gnu|armeb-openwrt-linux-gnu)
 +        host=arm-unknown-linux-gnueabi
 +        ;;
++    mips64-openwrt-linux-gnu)
++        host=mips64el-unknown-linux-gnuabi64
++        ;;
 +    *)
 +        host=$(echo $host | sed 's/openwrt/unknown/g')
 +        ;;