wpan-tools: update to 0.8
authorNick Hainke <vincent@systemli.org>
Mon, 4 Jul 2022 09:58:59 +0000 (11:58 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 10 Jul 2022 16:16:34 +0000 (18:16 +0200)
Remove upstreamed patches:
- 001-src-nl_extras.h-fix-compatibility-with-libnl-3.3.0.patch

Changes:
- examples: add README with details to the various examples
- examples: af_ieee802154_tx example
- examples: af_ieee802154_rx example
- examples: add af_packet_rx example
- examples: af_inet6_rx example
- examples: af_packet_tx example
- examples: af_inet6_tx example
- examples: add .gitignore file for examples directory
- src/nl_extras.h: fix compatibility with libnl 3.3.0
- wpan-ping: add the support to set wpan-ping interval
- wpan-ping: Add the filtering function for frame receiving

Signed-off-by: Nick Hainke <vincent@systemli.org>
package/network/utils/wpan-tools/Makefile
package/network/utils/wpan-tools/patches/001-src-nl_extras.h-fix-compatibility-with-libnl-3.3.0.patch [deleted file]

index 309a819cd4d3753678b8d97e1ffc2bc04d881b55..3491d82b442f9e02058111ea6acf28054e0a551e 100644 (file)
@@ -6,12 +6,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpan-tools
-PKG_VERSION:=0.7
+PKG_VERSION:=0.8
 PKG_RELEASE=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://github.com/linux-wpan/wpan-tools/releases/download/$(PKG_NAME)-$(PKG_VERSION)/$(PKG_NAME)-$(PKG_VERSION).tar.gz?
-PKG_HASH:=8b690ff0e71e08bece5ec541223fda7abd2d5552d97d3d25b4967609b58fef00
+PKG_HASH:=0e22cadbc40d4c12d0a66e8175bda12046f03237ce6da23d4fd26fd3ab557d8b
 
 include $(INCLUDE_DIR)/package.mk
 
diff --git a/package/network/utils/wpan-tools/patches/001-src-nl_extras.h-fix-compatibility-with-libnl-3.3.0.patch b/package/network/utils/wpan-tools/patches/001-src-nl_extras.h-fix-compatibility-with-libnl-3.3.0.patch
deleted file mode 100644 (file)
index 1370854..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-From bb522bd584f05e6658d5dba97f48ca018f46394c Mon Sep 17 00:00:00 2001
-From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-Date: Sat, 6 May 2017 14:36:08 +0200
-Subject: [PATCH] src/nl_extras.h: fix compatibility with libnl 3.3.0
-
-nl_extras.h defines a set of nla_set_s*() functions if not provided by
-libnl. They are provided by libnl since version 3.2.26. The test
-(LIBNL_VER_MIC <= 26) was working fine while libnl was in the 3.2.x
-series, but now that they have incremented the minor version, the
-micro version was reset to 0, with the latest libnl version being
-3.3.0.
-
-Due to this, the condition (LIBNL_VER_MIC <= 26) is true, and we get
-redefinition errors because nl_extras.h redefines functions already
-provided by libnl.
-
-This commit improves the condition so that nl_extras.h provides the
-missing functions only if the minor version is < 2, or if minor is 2
-and micro is < 26.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
----
- src/nl_extras.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
---- a/src/nl_extras.h
-+++ b/src/nl_extras.h
-@@ -1,7 +1,7 @@
- #ifndef __NL_EXTRAS_H
- #define __NL_EXTRAS_H
--#if LIBNL_VER_MIC <= 26
-+#if (LIBNL_VER_MIN < 2) || (LIBNL_VER_MIN == 2) && (LIBNL_VER_MIC <= 26)
- #ifndef NLA_S8
-@@ -45,6 +45,6 @@ static inline int32_t nla_get_s32(struct
- #endif /* NLA_S64 */
--#endif /* LIBNL_VER_MIC */
-+#endif /* LIBNL_VER_* */
- #endif /* __NL_EXTRAS_H */