strongswan: change name of config base directory 15436/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Thu, 15 Apr 2021 23:55:55 +0000 (17:55 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Thu, 15 Apr 2021 23:57:48 +0000 (17:57 -0600)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/gencerts.sh

index 3b45a2222f886c5fa4940f0cb9de64183d8679e0..a66645a70027a4f2771f25624d16d5eb3793aa1e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index 57dc0df6d6e3b2ff6ff2d2ec895b51079b686083..abd167b39d334e94f6a89d19ff91eec3172ff945 100755 (executable)
@@ -34,8 +34,8 @@ SHORT_DOMAIN="${DOMAIN%%.*}"
 ORG="$1"; shift
 
 # invariants...
-STRONGSWANDIR=/etc
-SWANCTL_DIR=$STRONGSWANDIR/swanctl
+SYSCONFDIR=/etc
+SWANCTL_DIR="$SYSCONFDIR/swanctl"
 : ${KEYINFO:="rsa:4096"}
 : ${CADAYS:=3650}
 : ${CRTDAYS:=730}
@@ -140,7 +140,7 @@ ROOTDN="$(makeDN "$C" "$ORG" "Root CA")"
 
 [ -f "$SWANCTL_DIR/x509ca/$SHORT_DOMAIN.crt" ] || genca
 
-PARENT="$STRONGSWANDIR"
+PARENT="$SYSCONFDIR"
 BASEDIR="${SWANCTL_DIR##$PARENT/}"
 
 for name in "$@"; do