projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f8c315b
)
workaround a bootloader bug on the WBD111
author
Imre Kaloz
<kaloz@openwrt.org>
Wed, 13 May 2009 10:59:59 +0000
(10:59 +0000)
committer
Imre Kaloz
<kaloz@openwrt.org>
Wed, 13 May 2009 10:59:59 +0000
(10:59 +0000)
SVN-Revision: 15818
target/linux/gemini/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/gemini/image/Makefile
b/target/linux/gemini/image/Makefile
index 6fb77506497e6ab77ae00efbe7f42705190ee7e0..fc69ffcc8123ca03f322871c3aea1fd84abb6691 100644
(file)
--- a/
target/linux/gemini/image/Makefile
+++ b/
target/linux/gemini/image/Makefile
@@
-14,7
+14,9
@@
define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/openwrt-$(BOARD)-wbd111-zImage $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+# workaround the bootloader's bug with extra nops
+ echo -en "\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1\x00\x00\xa0\xe1" > $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
+ cat $(KDIR)/openwrt-$(BOARD)-wbd111-zImage >> $(BIN_DIR)/openwrt-$(BOARD)-wbd111-zImage
endef
define Image/Build/jffs2-64k