hamlib: avoid build failures with spurious libraries
authorSteven Barth <steven@midlink.org>
Sun, 15 Jun 2014 07:40:00 +0000 (09:40 +0200)
committerSteven Barth <steven@midlink.org>
Sun, 15 Jun 2014 07:42:08 +0000 (09:42 +0200)
* always use libusb >= 1.0 (avoid pulling libusb-compat)
* never use libxml2

Signed-off-by: Steven Barth <steven@midlink.org>
utils/hamlib/Makefile
utils/hamlib/patches/100-override-autoconf-detection.patch [new file with mode: 0644]

index 40909ea7ef7fe3667f5020f14ba28fac6b040365..f43566386e824e5fceb3ca04f6413cb1cf0dc314 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hamlib
 PKG_VERSION:=1.2.15.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=3cad8987e995a00e5e9d360e2be0eb43
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
diff --git a/utils/hamlib/patches/100-override-autoconf-detection.patch b/utils/hamlib/patches/100-override-autoconf-detection.patch
new file mode 100644 (file)
index 0000000..284cc3b
--- /dev/null
@@ -0,0 +1,30 @@
+Index: hamlib-1.2.15.3/configure.ac
+===================================================================
+--- hamlib-1.2.15.3.orig/configure.ac  2012-11-01 22:27:27.000000000 +0100
++++ hamlib-1.2.15.3/configure.ac       2014-06-15 09:34:25.557966205 +0200
+@@ -234,12 +234,12 @@
+               "You need a C99 compliant C compiler that supports struct/array intializers."
+               "Have you considered GCC lately?.")]);
+-dnl libxml2 required rigmem xml support
+-PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
+-      [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
+-      [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
++#dnl libxml2 required rigmem xml support
++#PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
++#     [AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
++#     [AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
+ AC_SUBST(LIBXML2_LIBS)
+ AC_SUBST(LIBXML2_CFLAGS)
+ dnl Check if libgd-dev is installed, so we can enable rigmatrix
+@@ -406,7 +406,7 @@
+ AM_CONDITIONAL(HAVE_USRP, test x"${cf_with_usrp}" = "xyes")
+-PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1, ,
++PKG_CHECK_MODULES(LIBUSB, libusb >= 1.0, ,
+                 [AC_MSG_WARN([libusb pkg-config not found, USB backends will be disabled])])
+ CFLAGS="${CFLAGS} ${LIBUSB_CFLAGS}"
+ CXXFLAGS="${CXXFLAGS} ${LIBUSB_CFLAGS}"