ramips: add support for XiaoYu XY-C5
authorQi Jiang <rushx@live.cn>
Sun, 8 Sep 2019 01:52:07 +0000 (09:52 +0800)
committerChuanhong Guo <gch981213@gmail.com>
Wed, 25 Sep 2019 06:44:36 +0000 (14:44 +0800)
Hardware:
SoC:      MT7621A
Flash:    32 MiB
RAM:      512 MiB
Ethernet: built-in switch
USB:      1x USB3.0
SATA:     ASM1060, 1 SATA port

Flash instruction (TFTP):
1. Set PC to fixed ip address 192.168.173.22
2. Download *-sysupgrade.bin image and rename it to firmware.img
3. Start a tftp server with the image file in its root directory
4. Turn off the router
5. Turn on router,press the reset button and wait ~15 seconds
6. Release the reset button and after a short time
   the firmware should be transferred from the tftp server
7. Wait ~3 minutes to complete recovery.

Signed-off-by: Qi Jiang <rushx@live.cn>
[squash commits, add label-mac-device, fix sign-off style]
Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk

index 63644331e5d0005664bb8db430ef31469354d483..8af534dbc25a84299d9d46892a25381fbcaf1078 100755 (executable)
@@ -88,6 +88,7 @@ ramips_setup_interfaces()
        wavlink,wl-wn575a3|\
        xiaomi,miwifi-mini|\
        xiaomi,miwifi-nano|\
+       xiaoyu,xy-c5|\
        xzwifi,creativebox-v1|\
        youku,yk-l2|\
        youku,yk1|\
diff --git a/target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts b/target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts
new file mode 100644 (file)
index 0000000..072b2cc
--- /dev/null
@@ -0,0 +1,104 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+       compatible = "xiaoyu,xy-c5", "mediatek,mt7621-soc";
+       model = "XiaoYu XY-C5";
+
+       aliases {
+               led-boot = &led_sys;
+               led-failsafe = &led_sys;
+               led-running = &led_sys;
+               led-upgrade = &led_sys;
+               label-mac-device = &ethernet;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               work {
+                       label = "xy-c5:green:work";
+                       gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+               };
+
+               led_sys: sys {
+                       label = "xy-c5:green:sys";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x1fb0000>;
+                       };
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "uart3", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
index f098976dfce9aac05820d92395334ebe68d5e7a9..644f98419751a55717ee3b1825419a42071230dd 100644 (file)
@@ -768,6 +768,15 @@ define Device/xiaomi_mir3p
 endef
 TARGET_DEVICES += xiaomi_mir3p
 
+define Device/xiaoyu_xy-c5
+  MTK_SOC := mt7621
+  IMAGE_SIZE := 32448k
+  DEVICE_VENDOR := XiaoYu
+  DEVICE_MODEL := XY-C5
+  DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3
+endef
+TARGET_DEVICES += xiaoyu_xy-c5
+
 define Device/xzwifi_creativebox-v1
   MTK_SOC := mt7621
   IMAGE_SIZE := 32448k