isc-dhcp: properly anchor SRV RR's 17718/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Sat, 29 Jan 2022 04:32:53 +0000 (21:32 -0700)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Sat, 29 Jan 2022 04:32:53 +0000 (21:32 -0700)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/isc-dhcp/Makefile
net/isc-dhcp/files/dhcpd.init

index 46921ba3f329ea87c4bdae4fc958ca2545de61f6..567c93a47aa99435f1fe5d9ee97ffb58451dd675 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=isc-dhcp
 UPSTREAM_NAME:=dhcp
 PKG_VERSION:=4.4.1
-PKG_RELEASE:=18
+PKG_RELEASE:=19
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSE
index 680c112d132448bc3f413aba69e59a60bc35d18b..ab25b325843d4d354abec7ca1e64da923e99c9de 100755 (executable)
@@ -247,7 +247,7 @@ static_srvhost_add() {
        config_get weight "$cfg" "weight"
        [ -n "$weight" ] || return 0
 
-       update "$srv.$domain." IN SRV "$priority" "$weight" "$port" "$target"
+       update "$srv.$domain." IN SRV "$priority" "$weight" "$port" "$target.$domain"
 }
 
 static_srvhosts() {