gptfdisk: fix incorrect TARGET on non-linux host
authorGeorgi Valkov <gvalkov@gmail.com>
Tue, 8 Aug 2023 07:27:26 +0000 (10:27 +0300)
committerRosen Penev <rosenp@gmail.com>
Wed, 9 Aug 2023 21:54:45 +0000 (14:54 -0700)
Fixed by defining TARGET=linux, as suggested in the README.

By default TARGET is derived from the host using uname -s,
which produces build errors on a non-linux hosts:

TARGET is not set; trying to determine target based on host OS....
Detected OS is Darwin
Build target is macos
...
x86_64-openwrt-linux-musl-g++: error: unrecognized command-line option '-arch'

Helped-by: Tianling Shen <cnsztl@immortalwrt.org>
Signed-off-by: Georgi Valkov <gvalkov@gmail.com>
utils/gptfdisk/Makefile

index 35f34d0a48d7f13c1ded4dc3960566f9fcd2222d..4f667166e7c56e6b93b55f84a65a45dfc2c876d2 100644 (file)
@@ -75,6 +75,7 @@ endef
 
 TARGET_CXXFLAGS += -std=c++11 -fno-rtti
 TARGET_LDFLAGS += -Wl,--as-needed
+MAKE_FLAGS += TARGET=linux
 
 define Package/gdisk/install
        $(INSTALL_DIR) $(1)/usr/bin