dovecot: Fix iconv macro is missing compile error
authorJuan del Bosque <juan@web64.pro>
Fri, 14 Apr 2023 07:48:22 +0000 (09:48 +0200)
committerTianling Shen <cnsztl@gmail.com>
Wed, 10 May 2023 06:02:20 +0000 (14:02 +0800)
Fix a Dovecot compile error when building with no other packages than
the default in master build, because iconv macro is missing.

Fixes: #20677
Signed-off-by: Juan del Bosque <juan@web64.pro>
mail/dovecot/Makefile

index d1c034edaa48b536ab860e3f95d166bb56f88653..8f9e66e153e8294ab8c0b312c36df830290f0fbd 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dovecot
 PKG_VERSION:=2.3.18
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://dovecot.org/releases/2.3
@@ -37,6 +37,9 @@ include $(INCLUDE_DIR)/package.mk
 # dovecot itself.
 include $(INCLUDE_DIR)/nls.mk
 
+# need iconv.m4, otherwise error during autoreconf
+PKG_BUILD_DEPENDS:=gettext-full
+
 define Package/dovecot
   SECTION:=mail
   CATEGORY:=Mail