postgresql: update to version 12.4
authorDaniel Golle <daniel@makrotopia.org>
Sun, 30 Aug 2020 17:52:47 +0000 (18:52 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 30 Aug 2020 17:54:48 +0000 (18:54 +0100)
Fixes CVE-2020-14349 and CVE-2020-14350.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
libs/postgresql/Makefile
libs/postgresql/patches/001-configure_fixes.patch
libs/postgresql/patches/900-pg_ctl-setuid.patch

index f7d8395a3e994b033ce20dc6b092896dc0c04e8e..9090289b114e0f5618e0da13d8f0268d2b52e91e 100644 (file)
@@ -5,7 +5,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=postgresql
-PKG_VERSION:=12.3
+PKG_VERSION:=12.4
 PKG_RELEASE:=1
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=PostgreSQL
@@ -17,7 +17,7 @@ PKG_SOURCE_URL:=\
        http://ftp.postgresql.org/pub/source/v$(PKG_VERSION) \
        ftp://ftp.postgresql.org/pub/source/v$(PKG_VERSION)
 
-PKG_HASH:=94ed64a6179048190695c86ec707cc25d016056ce10fc9d229267d9a8f1dcf41
+PKG_HASH:=bee93fbe2c32f59419cb162bcc0145c58da9a8644ee154a30b9a5ce47de606cc
 
 PKG_USE_MIPS16:=0
 PKG_FIXUP:=autoreconf
index 149189c4971601c6177bea93f7a818f4d51e82a6..02d345fdf3a01c011c663adffcf95b4f1df94f78 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.in
 +++ b/configure.in
-@@ -2285,36 +2285,6 @@ if test "$with_python" = yes; then
+@@ -2317,36 +2317,6 @@ if test "$with_python" = yes; then
    CPPFLAGS=$ac_save_CPPFLAGS
  fi
  
index 346d08b71060381165f35457c57826ef9cd6dee6..48575777cd4d7b574ae87c2295eb6c665f62fda7 100644 (file)
@@ -8,7 +8,7 @@
  static char *argv0 = NULL;
  static bool allow_core_files = false;
  static time_t start_time;
-@@ -2047,6 +2048,9 @@ do_help(void)
+@@ -2082,6 +2083,9 @@ do_help(void)
  #endif
        printf(_("  -s, --silent           only print errors, no informational messages\n"));
        printf(_("  -t, --timeout=SECS     seconds to wait when using -w option\n"));
@@ -18,7 +18,7 @@
        printf(_("  -V, --version          output version information, then exit\n"));
        printf(_("  -w, --wait             wait until operation completes (default)\n"));
        printf(_("  -W, --no-wait          do not wait until operation completes\n"));
-@@ -2259,6 +2263,7 @@ main(int argc, char **argv)
+@@ -2294,6 +2298,7 @@ main(int argc, char **argv)
                {"options", required_argument, NULL, 'o'},
                {"silent", no_argument, NULL, 's'},
                {"timeout", required_argument, NULL, 't'},
@@ -26,7 +26,7 @@
                {"core-files", no_argument, NULL, 'c'},
                {"wait", no_argument, NULL, 'w'},
                {"no-wait", no_argument, NULL, 'W'},
-@@ -2299,20 +2304,6 @@ main(int argc, char **argv)
+@@ -2334,20 +2339,6 @@ main(int argc, char **argv)
                }
        }
  
@@ -47,7 +47,7 @@
  
        env_wait = getenv("PGCTLTIMEOUT");
        if (env_wait != NULL)
-@@ -2399,11 +2390,15 @@ main(int argc, char **argv)
+@@ -2434,11 +2425,15 @@ main(int argc, char **argv)
                                        wait_seconds_arg = true;
                                        break;
                                case 'U':
@@ -63,7 +63,7 @@
                                        break;
                                case 'w':
                                        do_wait = true;
-@@ -2485,6 +2480,41 @@ main(int argc, char **argv)
+@@ -2520,6 +2515,41 @@ main(int argc, char **argv)
                exit(1);
        }