wget: provides gnu-wget
authorYousong Zhou <yszhou4tech@gmail.com>
Mon, 9 Sep 2019 02:59:50 +0000 (02:59 +0000)
committertripolar <tripolar@users.noreply.github.com>
Mon, 9 Sep 2019 07:40:34 +0000 (09:40 +0200)
So that packages like acme requiring features from it can depend on it
explicitly, not the more basic "wget" which is also provided by
"uclient-fetch"

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/wget/Makefile

index 62aed759d0387a5b1066f7d511b099b1dd17a392..66a25f7ddd9970a9755c9f013c3f9b4caca78e30 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wget
 PKG_VERSION:=1.20.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
@@ -31,6 +31,7 @@ define Package/wget/Default
   SUBMENU:=File Transfer
   TITLE:=Non-interactive network downloader
   URL:=https://www.gnu.org/software/wget/index.html
+  PROVIDES:=wget
 endef
 
 define Package/wget/Default/description
@@ -47,6 +48,7 @@ $(call Package/wget/Default)
   DEPENDS+= +libopenssl +librt
   TITLE+= (with SSL support)
   VARIANT:=ssl
+  PROVIDES+=gnu-wget
   ALTERNATIVES:=300:/usr/bin/wget:/usr/bin/wget-ssl
 endef
 
@@ -59,6 +61,7 @@ define Package/wget-nossl
 $(call Package/wget/Default)
   TITLE+= (without SSL support)
   VARIANT:=nossl
+  PROVIDES+=gnu-wget
   ALTERNATIVES:=300:/usr/bin/wget:/usr/bin/wget-nossl
 endef