add global make download target
authorFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jun 2006 23:57:10 +0000 (23:57 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 20 Jun 2006 23:57:10 +0000 (23:57 +0000)
SVN-Revision: 4031

openwrt/Makefile

index 92a49bf9e81c9fe7abd8a56ebc34a80a3af85dd2..faeecaa4881e5c7dd2058f5d7ef2b82ba24b2349 100644 (file)
@@ -86,9 +86,16 @@ target/%: .pkginfo FORCE
 toolchain/%: FORCE
        $(MAKE) -C toolchain $(patsubst toolchain/%,%,$@)
 
-world: ./scripts/config/conf FORCE
-       touch .config
+.config: ./scripts/config/conf FORCE
+       @[ -f .config ] || $(MAKE) menuconfig
        $< -D .config Config.in >/dev/null 2>/dev/null
+
+download: .config FORCE
+       $(MAKE) toolchain/download
+       $(MAKE) package/download
+       $(MAKE) target/download
+
+world: .config FORCE
        $(MAKE) toolchain/install
        $(MAKE) target/compile
        $(MAKE) package/compile