mediatek: mt7623: simplify partition generation
authorDaniel Golle <daniel@makrotopia.org>
Mon, 31 Jan 2022 00:45:10 +0000 (00:45 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 31 Jan 2022 15:02:36 +0000 (15:02 +0000)
The two options 'emmc' and 'sdmmc' now became identical lines after
introducing CONFIG_TARGET_ROOTFS_PARTSIZE.
Remove the now useless if-clauses.

Fixes: a40b4d335a ("mediatek: use CONFIG_TARGET_ROOTFS_PARTSIZE")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/mediatek/image/mt7623.mk

index 16f59790b042e3e164f3ea9e0cd19f307282b092..4ef0aabe4da9e4a7c6879fe232642a09f0dd8b61 100644 (file)
@@ -57,12 +57,7 @@ define Build/mt7623-mbr
        ptgen -o $@.tmp -h 4 -s 63 -a 0 -l 1024 \
                        -t 0x41 -N uboot        -p 1M@$(UBOOT_OFFSET) \
                        -t 0xea -N recovery     -p 40M@4M \
-               $(if $(findstring sdmmc,$1), \
-                       -t 0x2e -N production   -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
-               ) \
-               $(if $(findstring emmc,$1), \
-                       -t 0x2e -N production   -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M \
-               )
+                       -t 0x2e -N production   -p $(CONFIG_TARGET_ROOTFS_PARTSIZE)M@48M
 
        echo -en \
                $(if $(findstring sdmmc,$1),"SDMMC_BOOT\x00\x00\x01\x00\x00\x00\x00\x02\x00\x00") \