prereq-build: diff requirement to GNU
authorRosen Penev <rosenp@gmail.com>
Sat, 12 Jun 2021 23:02:29 +0000 (16:02 -0700)
committerPaul Spooren <mail@aparcar.org>
Sun, 13 Jun 2021 01:54:13 +0000 (15:54 -1000)
tools/quilt requires GNU diffutils to compile. Failure can be simulated
by installing Alpine Linux without diffutils.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
include/prereq-build.mk

index 639d1ad0face54f6075475f441858bd10cff6d82..8fbf6f22c4e5352ef61164fdb35ec66b970c73cd 100644 (file)
@@ -102,9 +102,9 @@ $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
        gpatch --version 2>&1 | grep 'Free Software Foundation', \
        patch --version 2>&1 | grep 'Free Software Foundation'))
 
-$(eval $(call SetupHostCommand,diff,Please install diffutils, \
-       gdiff --version 2>&1 | grep diff, \
-       diff --version 2>&1 | grep diff))
+$(eval $(call SetupHostCommand,diff,Please install GNU diffutils, \
+       gdiff --version 2>&1 | grep GNU, \
+       diff --version 2>&1 | grep GNU))
 
 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
        gcp --help 2>&1 | grep 'Copy SOURCE', \