freeswitch-stable: use pg_config for now 504/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 7 Mar 2020 08:58:24 +0000 (09:58 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 7 Mar 2020 08:58:26 +0000 (09:58 +0100)
libpq's pkg-config file is currently broken. Use pg_config instead.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/freeswitch-stable/Makefile

index ee332c7bd56461c08432652d56a9321cd5265db8..3f6b77d229b13f84f1ad92f8e48e3ff09257877e 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PRG_NAME:=freeswitch
 PKG_NAME:=$(PRG_NAME)-stable
 PKG_VERSION:=1.10.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>
 
 PKG_SOURCE:=$(PRG_NAME)-$(PKG_VERSION).-release.tar.xz
@@ -674,6 +674,11 @@ endif
 CONFIGURE_ARGS+= \
        --without-pgsql
 
+# libpq pkg-config file is broken, see
+# https://github.com/openwrt/packages/pull/11507
+CONFIGURE_ARGS+= \
+       --disable-core-pgsql-pkgconfig
+
 # Don't want host-php
 CONFIGURE_VARS+= \
        ac_cv_have_php=no \