Merge pull request #17395 from mhei/fix-issue-17332-php8-pecl-http-compile-failure
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 20 Dec 2021 09:36:18 +0000 (11:36 +0200)
committerGitHub <noreply@github.com>
Mon, 20 Dec 2021 09:36:18 +0000 (11:36 +0200)
php8-pecl-http: add compile-time hint about TLS13 ciphers (fixes #17332)

lang/php8-pecl-http/Makefile

index c5ff0a52abc2578d7dbb7489fc05ab87ddd7e8b9..3caea50f1b2e538ead958dee453d6c591fa28155 100644 (file)
@@ -9,7 +9,7 @@ PECL_NAME:=pecl_http
 PECL_LONGNAME:=Extended HTTP Support
 
 PKG_VERSION:=4.2.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_HASH:=ab07d55ccdfa897c897c26f1c0851b557b363431766c9ea4c799ea61443bdcdc
 
 PKG_NAME:=php8-pecl-http
@@ -43,6 +43,7 @@ CONFIGURE_VARS+= \
        PECL_cv_HAVE_LIBCURL_axTLS=no \
        PECL_cv_LIBCURL_TLSAUTH_SRP=$(if $(CONFIG_LIBCURL_TLS_SRP),yes,no) \
        PECL_cv_LIBCURL_SHARE_SSL=yes \
+       PECL_cv_LIBCURL_TLS13_CIPHERS=$(if $(CONFIG_OPENSSL_WITH_TLS13),yes,no) \
 
 CONFIGURE_ARGS+= \
        --with-http \