lxc: use -minterlink-mips16 only with USE_MIPS16 12265/head
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Sat, 23 May 2020 16:01:13 +0000 (13:01 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Sat, 23 May 2020 20:37:14 +0000 (17:37 -0300)
The flag is either not supported or not needed unless there's mixed
mips/mips16 code.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
utils/lxc/Makefile

index f31c5f3b83c3b8af74f902febb17e07bfed9945f..0a5c37992963875e749799546452679adcacb7db 100644 (file)
@@ -142,7 +142,9 @@ CONFIGURE_ARGS += \
        --enable-capabilities \
        --disable-examples
 
-TARGET_CFLAGS += -minterlink-mips16
+ifdef CONFIG_USE_MIPS16
+  TARGET_CFLAGS += -minterlink-mips16
+endif
 TARGET_LDFLAGS += -lgcc_eh
 
 define Build/InstallDev