gstreamer1: update to 1.20.2
authorW. Michael Petullo <mike@flyn.org>
Wed, 11 May 2022 00:37:35 +0000 (19:37 -0500)
committerRosen Penev <rosenp@gmail.com>
Wed, 11 May 2022 21:51:01 +0000 (17:51 -0400)
Signed-off-by: W. Michael Petullo <mike@flyn.org>
multimedia/gstreamer1/Makefile
multimedia/gstreamer1/patches/010-gstplugin-use-lazy-symbol-binding.patch
multimedia/gstreamer1/patches/020-distutils.patch

index a7cb7d056f69d835c7a095ee371c083a6dd799a0..c1e38a2dab189023e45b39b15228c064c956656a 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
-PKG_VERSION:=1.18.5
+PKG_VERSION:=1.20.2
 PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
-PKG_HASH:=55862232a63459bbf56abebde3085ca9aec211b478e891dacea4d6df8cafe80a
+PKG_HASH:=df24e8792691a02dfe003b3833a51f1dbc6c3331ae625d143b17da939ceb5e0a
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
@@ -134,7 +134,6 @@ MESON_ARGS += \
        -Dexamples=disabled \
        -Dbenchmarks=disabled \
        -Dtools=enabled \
-       -Dgtk_doc=disabled \
        -Dintrospection=disabled \
        -Dnls=enabled \
        -Dgobject-cast-checks=disabled \
index 910bc26a703495d5c35ac2a952a89535e0210393..8cf5238ab94c311fb20543b795f9a51b6188a07a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gst/gstplugin.c
 +++ b/gst/gstplugin.c
-@@ -790,15 +790,8 @@ _priv_gst_plugin_load_file_for_registry
+@@ -851,15 +851,8 @@ _priv_gst_plugin_load_file_for_registry
    }
  #endif
  
index e530f24617434a240976c4f0059854ed46acfa28..7dfbe7d3b9d67d218d64d00fa14d7baba32259c8 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -522,7 +522,7 @@ if get_option('default_library') == 'sta
+@@ -528,7 +528,7 @@ if get_option('default_library') == 'sta
  endif
  
  # Used in gst/parse/meson.build and below