libxslt: remove $(FPIC) from TARGET_CFLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 11:02:48 +0000 (12:02 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 24 Feb 2018 11:02:49 +0000 (12:02 +0100)
libxslt already makes sure that the compiler emits position-independent
code. Adding $(FPIC) makes no difference. In addition the libxslt build
system puts its own flag behind the CFLAGS, overriding whatever was set
before.

Also with $(FPIC) in CFLAGS even the libxslt utils get compiled with
PIC, which us undesirable.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
libs/libxslt/Makefile

index 9f276d3fd2b4af0c2aa5b1beccf6d8b7137c5005..4de05972433895c06dac009c561e58fdfbdf704c 100644 (file)
@@ -73,8 +73,6 @@ CONFIGURE_ARGS+= \
        --without-mem-debug \
        --without-debugger \
 
-TARGET_CFLAGS += $(FPIC)
-
 define Build/InstallDev/Xslt
        $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
                $(1)/usr/include/libexslt $(1)/usr/lib \