hfsprogs: fix when not linking aginst glibc 4275/head
authorMatthew McClintock <msm-oss@mcclintock.net>
Tue, 18 Apr 2017 17:36:23 +0000 (12:36 -0500)
committerMatthew McClintock <msm-oss@mcclintock.net>
Tue, 18 Apr 2017 17:37:00 +0000 (12:37 -0500)
Only link with libbsd when we are using GLIBC

Signed-off-by: Matthew McClintock <msm-oss@mcclintock.net>
utils/hfsprogs/Makefile

index 6b907523cf8f4fd43aaed353ea012fae6f0d42c7..b260c9077d08fbc9bb7714d04644fe61729f8045 100644 (file)
@@ -60,7 +60,7 @@ define Build/Compile
                -f Makefile.lnx \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS+="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(PKG_BUILD_DIR)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1" \
-               LDFLAGS+="$(TARGET_LDFLAGS) -lbsd" \
+               LDFLAGS+="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lbsd)" \
                all
 endef