[luci] luci-app-advanced-reboot: add board config for Linksys EA7500-V1 5074/head
authorDavid Adair <djabhead@aol.com>
Thu, 20 May 2021 04:25:38 +0000 (21:25 -0700)
committerDavid Adair <djabhead@aol.com>
Wed, 26 May 2021 23:07:06 +0000 (16:07 -0700)
EA7500-v1 works the same as the other Linksys models except
the name is different.

Signed-off-by: David Adair <djabhead@aol.com>
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v1.json [new file with mode: 0644]

index 8b3f709dfa279ab8aab4ed39d93c32b3da229552..a0024cdc1f03dcff3b0880b5c0accd02574ad0aa 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-1
+PKG_VERSION:=1.0.1-2
 
 LUCI_TITLE:=Advanced Linksys Reboot Web UI
 LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
diff --git a/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v1.json b/applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-ea7500v1.json
new file mode 100644 (file)
index 0000000..4c68639
--- /dev/null
@@ -0,0 +1,14 @@
+{
+       "vendorName": "Linksys",
+       "deviceName": "EA7500v1",
+       "boardNames": [ "linksys,ea7500-v1" ],
+       "partition1MTD": "mtd13",
+       "partition2MTD": "mtd15",
+       "labelOffset": 32,
+       "bootEnv1": "boot_part",
+       "bootEnv1Partition1Value": 1,
+       "bootEnv1Partition2Value": 2,
+       "bootEnv2": null,
+       "bootEnv2Partition1Value": null,
+       "bootEnv2Partition2Value": null
+}