build asterisk correctly with DEVELOPER=1 and not all config options enabled
authorFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jun 2005 10:18:37 +0000 (10:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 5 Jun 2005 10:18:37 +0000 (10:18 +0000)
SVN-Revision: 1144

openwrt/package/asterisk/Makefile

index 5c5dd7bf0154438af315978101778725621f8238..b39a529e57245c6d879daed5f1e47a89b217641b 100644 (file)
@@ -23,6 +23,11 @@ $(eval $(call PKG_template,ASTERISK_CODEC_LPC10,asterisk-codec-lpc10,$(PKG_VERSI
 $(eval $(call PKG_template,ASTERISK_CODEC_SPEEX,asterisk-codec-speex,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_PBX_DUNDI,asterisk-pbx-dundi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
+ifneq ($(DEVELOPER),)
+APPS:=app_sql_mysql.so app_sql_postgres.so
+MODS:=cdr_mysql.so cdr_pgsql.so
+SPEEX:=codec_speex.so
+else
 APPS:=
 MODS:=
 ifneq ($(BR2_PACKAGE_ASTERISK_MYSQL),)
@@ -36,6 +41,7 @@ endif
 ifneq ($(BR2_PACKAGE_ASTERISK_CODEC_SPEEX),)
 SPEEX:=codec_speex.so
 endif
+endif
 
 $(PKG_BUILD_DIR)/.configured:
        touch $@