strongswan: force PIC on all builds
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 24 Feb 2021 21:46:33 +0000 (14:46 -0700)
committerPaul Spooren <mail@aparcar.org>
Mon, 5 Apr 2021 17:31:40 +0000 (07:31 -1000)
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/patches/305-minimal_dh_plugin.patch

index 7b8e215b73d25c833ebe89900b4cfe8bd3cd58fd..64c92ea7ddf3be67b1e76d8316d36cfd1693046f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.1
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index dcd244885a1067946be982c1712c3e0e6f327758..59af4f405497d3235a4dea542ae5410decad4dce 100644 (file)
@@ -68,7 +68,7 @@
 +      ../gmp/gmp_diffie_hellman.c ../gmp/gmp_diffie_hellman.h 
 +
 +      
-+libstrongswan_gmpdh_la_LDFLAGS = -module -avoid-version -Wl,-Bstatic -Wl,-lgmp -Wl,-Bdynamic -Wl,--as-needed
++libstrongswan_gmpdh_la_LDFLAGS = -module -avoid-version -Wl,-Bstatic -Wl,-lgmp -Wl,-Bdynamic -Wl,--as-needed $(FPIC)
 +libstrongswan_gmpdh_la_LIBADD  =
 --- /dev/null
 +++ b/src/libstrongswan/plugins/gmpdh/gmpdh_plugin.c