strongswan: start charon directly from swanctl 15753/head
authorPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 2 Jun 2021 02:13:14 +0000 (20:13 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Wed, 2 Jun 2021 06:23:54 +0000 (00:23 -0600)
ipsec uses starter, and reads /etc/ipsec.conf (which then includes
/var/ipsec/ipsec.conf, etc). This is overly complicated, and can
be problematic if you're using both swanctl and ipsec for migration.

Running charon directly from procd via the init.d script avoid
all of this.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/strongswan/Makefile
net/strongswan/files/swanctl.init

index f68bf1b98d71d10774114961d0fa3ff6fd198333..09452d75194969e443c2fab9eeaca4d5c4ae4877 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strongswan
 PKG_VERSION:=5.9.2
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://download.strongswan.org/ https://download2.strongswan.org/
index a1fb7c31131c8541bebc9ae7ccd53de7651d3c25..f83d11fc31f1a4a1370255235272c524e2952419 100644 (file)
@@ -4,7 +4,7 @@ START=90
 STOP=10
 
 USE_PROCD=1
-PROG=/usr/lib/ipsec/starter
+PROG=/usr/lib/ipsec/charon
 
 . $IPKG_INSTROOT/lib/functions.sh
 . $IPKG_INSTROOT/lib/functions/network.sh
@@ -614,7 +614,7 @@ start_service() {
 
        procd_open_instance
 
-       procd_set_param command $PROG --daemon charon --nofork
+       procd_set_param command $PROG
 
        procd_set_param file $SWANCTL_CONF_FILE
        procd_append_param file /etc/swanctl/conf.d/*.conf