Change libpcap, uniformize package makefile, put control file in ./ipkg
authorNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 22:40:59 +0000 (22:40 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 22:40:59 +0000 (22:40 +0000)
SVN-Revision: 683

openwrt/package/tcpdump/Makefile
openwrt/package/tcpdump/ipkg/tcpdump.control [new file with mode: 0644]
openwrt/package/tcpdump/tcpdump.control [deleted file]

index 2b854c8285faf86de77aae11c88d8b5012053354..cf74ea5f17bed77072815ddb327d6d379e8f3a53 100644 (file)
@@ -68,10 +68,10 @@ $(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
                CCOPT="$(TARGET_CFLAGS)" INCLS="-I. -I$(STAGING_DIR)/usr/include"
 
 $(IPKG_TCPDUMP): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_TCPDUMP) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(IDIR_TCPDUMP)/usr/sbin
-       cp $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_TCPDUMP)/usr/sbin/
-       $(STRIP) $(IDIR_TCPDUMP)/usr/sbin/*
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_TCPDUMP) ./ipkg/$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       install -m0755 -d $(IDIR_TCPDUMP)/usr/sbin
+       install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_TCPDUMP)/usr/sbin/
+       $(RSTRIP) $(IDIR_TCPDUMP)
        mkdir -p $(PACKAGE_DIR)
        $(IPKG_BUILD) $(IDIR_TCPDUMP) $(PACKAGE_DIR)
 
@@ -84,4 +84,5 @@ compile: $(IPKG_TCPDUMP)
 install: $(INFO_TCPDUMP)
 
 clean:
-       rm -rf $(PKG_BUILD_DIR) $(IPKG_TCPDUMP)
+       rm -rf $(PKG_BUILD_DIR)
+       rm -rf $(IPKG_TCPDUMP)
diff --git a/openwrt/package/tcpdump/ipkg/tcpdump.control b/openwrt/package/tcpdump/ipkg/tcpdump.control
new file mode 100644 (file)
index 0000000..8817389
--- /dev/null
@@ -0,0 +1,7 @@
+Package: tcpdump
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: A tool for network monitoring and data acquisition.
+Depends: libpcap
diff --git a/openwrt/package/tcpdump/tcpdump.control b/openwrt/package/tcpdump/tcpdump.control
deleted file mode 100644 (file)
index 8817389..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: tcpdump
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: A tool for network monitoring and data acquisition.
-Depends: libpcap