openconnect: bump to version 9.01 18520/head
authorRui Salvaterra <rsalvaterra@gmail.com>
Thu, 12 May 2022 09:22:19 +0000 (10:22 +0100)
committerRui Salvaterra <rsalvaterra@gmail.com>
Thu, 12 May 2022 10:17:59 +0000 (11:17 +0100)
Now with basic support for the Array Networks SSL VPN protocol.

Also fix the OpenSSL build. OpenConnect requires support for deprecated APIs,
for the time being, so select them if compiling against OpenSSL.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
net/openconnect/Config.in
net/openconnect/Makefile

index d73bd3a88d08dec7084487a63da4f8445e5c4cf9..7a468eeb8d28911430bfdb0685a1e1b760efa338 100644 (file)
@@ -12,6 +12,7 @@ config OPENCONNECT_GNUTLS
 
 config OPENCONNECT_OPENSSL
        bool "OpenSSL"
+       select OPENSSL_WITH_DEPRECATED
 
 endchoice
 
index 2abaf614f533fcbca9ab2cae36e57e2de7a74859..6bf724eeb6b35e06cd504d140f3c1fd555522e3b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openconnect
-PKG_VERSION:=8.20
+PKG_VERSION:=9.01
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
-PKG_HASH:=c1452384c6f796baee45d4e919ae1bfc281d6c88862e1f646a2cc513fc44e58b
+PKG_HASH:=b3d7faf830e9793299d6a41e81d84cd4a3e2789c148c9e598e4585010090e4c7
 
 PKG_LICENSE:=LGPL-2.1-or-later
 PKG_LICENSE_FILES:=COPYING.LGPL