kernel: bump 4.9 to 4.9.168
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 11:50:17 +0000 (13:50 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 8 Apr 2019 12:54:48 +0000 (14:54 +0200)
Refreshed all patches.

Compile-tested on: ar71xx
Runtime-tested on: ar71xx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/ar71xx/patches-4.9/930-chipidea-pullup.patch
target/linux/brcm2708/patches-4.9/950-0056-fbdev-add-FBIOCOPYAREA-ioctl.patch
target/linux/generic/hack-4.9/902-debloat_proc.patch

index 22644742226ec7bc00381c31dd518dd24f7df70c..20ba2f32af42598286b15c81fb083d647abcc5ea 100644 (file)
@@ -2,10 +2,10 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-4.9 = .167
+LINUX_VERSION-4.9 = .168
 LINUX_VERSION-4.14 = .110
 
-LINUX_KERNEL_HASH-4.9.167 = a2b8608a2fe7a6203ed46c3a3d55091b19ac8304dded6338410a361dc63f0a8c
+LINUX_KERNEL_HASH-4.9.168 = 4d451c21effad77de323edc9bfeae095aa1faed1a801ef427d66f5763bef091e
 LINUX_KERNEL_HASH-4.14.110 = 99ea359464dc8a7ab9862195934a1f3504c38a32af5fa424e3ae56244dd59e72
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index 1c4ef3891c5f7d706d891679cd2fc28da2634c04..04a3ec1eeb2fb7287480ec9a0fa750646c87c8b4 100644 (file)
@@ -37,7 +37,7 @@
        ret = hw_device_init(ci, base);
        if (ret < 0) {
                dev_err(dev, "can't initialize hardware\n");
-@@ -963,7 +966,7 @@ static int ci_hdrc_probe(struct platform
+@@ -970,7 +973,7 @@ static int ci_hdrc_probe(struct platform
                goto deinit_gadget;
        }
  
index c7160c7b2e027482242b38878aa1dc7eccb156de..4966a99ba68906f5cffa2d8b55476dd72d37159b 100644 (file)
@@ -154,7 +154,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
                return -ENOTTY;
 --- a/drivers/video/fbdev/core/fbmem.c
 +++ b/drivers/video/fbdev/core/fbmem.c
-@@ -1088,6 +1088,31 @@ fb_blank(struct fb_info *info, int blank
+@@ -1091,6 +1091,31 @@ fb_blank(struct fb_info *info, int blank
  }
  EXPORT_SYMBOL(fb_blank);
  
@@ -186,7 +186,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
  static long do_fb_ioctl(struct fb_info *info, unsigned int cmd,
                        unsigned long arg)
  {
-@@ -1098,6 +1123,7 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1101,6 +1126,7 @@ static long do_fb_ioctl(struct fb_info *
        struct fb_cmap cmap_from;
        struct fb_cmap_user cmap;
        struct fb_event event;
@@ -194,7 +194,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        void __user *argp = (void __user *)arg;
        long ret = 0;
  
-@@ -1215,6 +1241,15 @@ static long do_fb_ioctl(struct fb_info *
+@@ -1218,6 +1244,15 @@ static long do_fb_ioctl(struct fb_info *
                unlock_fb_info(info);
                console_unlock();
                break;
@@ -210,7 +210,7 @@ bcm2708_fb: Add ioctl for reading gpu memory through dma
        default:
                if (!lock_fb_info(info))
                        return -ENODEV;
-@@ -1369,6 +1404,7 @@ static long fb_compat_ioctl(struct file
+@@ -1372,6 +1407,7 @@ static long fb_compat_ioctl(struct file
        case FBIOPAN_DISPLAY:
        case FBIOGET_CON2FBMAP:
        case FBIOPUT_CON2FBMAP:
index 91d1d283511b78e4db4be79eb839ad39d285a173..7c4a48f5ff4eedc28f8c06624405b1de416b9672 100644 (file)
@@ -233,7 +233,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                return -ENOMEM;
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2714,6 +2714,8 @@ static const struct file_operations proc
+@@ -2718,6 +2718,8 @@ static const struct file_operations proc
  
  static int __init proc_vmalloc_init(void)
  {