libevhtp: Add onigiruma.h to install 8986/head
authorRosen Penev <rosenp@gmail.com>
Tue, 14 May 2019 19:39:31 +0000 (12:39 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 May 2019 19:39:31 +0000 (12:39 -0700)
For some reason from 1.1.7 to 1.2.0, oniguruma no longer gets installed by
default. Fix that to fix compilation with seafile.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libevhtp/Makefile
libs/libevhtp/patches/040-oniguruma.patch [new file with mode: 0644]

index b1470ca7749b21b18852ea002177f4694c078345..5c39dc363a2a1cd8815d9ecd0aa287a1047d4958 100644 (file)
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libevhtp
 PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/criticalstack/libevhtp/tar.gz/$(PKG_VERSION)?
diff --git a/libs/libevhtp/patches/040-oniguruma.patch b/libs/libevhtp/patches/040-oniguruma.patch
new file mode 100644 (file)
index 0000000..5d457ab
--- /dev/null
@@ -0,0 +1,7 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -241,3 +241,4 @@ endif()
+ install (FILES evhtp.h DESTINATION include)
+ install (FILES htparse/htparse.h DESTINATION include)
+ install (FILES evthr/evthr.h DESTINATION include)
++install (FILES oniguruma/onigposix.h DESTINATION include)