Import intltool from oldpackages
authorTed Hess <thess@kitschensync.net>
Thu, 17 Jul 2014 20:52:21 +0000 (16:52 -0400)
committerTed Hess <thess@kitschensync.net>
Thu, 17 Jul 2014 22:04:55 +0000 (18:04 -0400)
libs/intltool/Makefile [new file with mode: 0644]

diff --git a/libs/intltool/Makefile b/libs/intltool/Makefile
new file mode 100644 (file)
index 0000000..e7fcb4d
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=intltool
+PKG_LIBVER:=0.40
+PKG_VERSION:=$(PKG_LIBVER).6
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNOME/intltool/$(PKG_LIBVER)
+PKG_MD5SUM:=69bc0353323112f42ad4f9cf351bc3e5
+
+PKG_HOST_ONLY:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/package.mk
+
+define Package/intltool
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=set of tools to centralize translation using GNU gettext
+  URL:=http://www.freedesktop.org/wiki/Software/intltool
+  BUILDONLY:=1
+endef
+
+define Package/intltool/description
+  intltool is a set of tools to centralize translation of many different
+  file formats using GNU gettext-compatible PO files.
+endef
+
+define Require/perl-xml-parser
+  perl -e 'use XML::Parser;'
+endef
+
+$(eval $(call Require,perl-xml-parser, \
+       Please install Perl XML::Parser \
+))
+
+$(eval $(call BuildPackage,intltool))
+$(eval $(call HostBuild))